Amp Crackling


PDA

View Full Version : Amp Crackling


monarch
12-16-2006, 06:07 PM
Hey guys, just bought my second guitar, which is also my first electric. I was on a budget, so I had to buy a lower-end model. It's an Aria STG Series, and the amp is a Groove Factory GF-10G. The guitar is pretty good for the price.

But, my amp crackles a lot when i turn it on, but then it stops after about 3 or 4 minutes. This happens regardless of whether my guitar, or even the cable, is plugged in or not.

Also, it hums when i turn it up to around 8 or 9, but that's probably normal. But when I touch the strings, the boost switch or the screws around the pickups and the switches, it reduces considerably (although its still there), sort of like a 'channel' of humming got switched off.

Could anyone help me with this, please? Is this normal, or should I go and return the amp and get another one of the same make?

Cheers :)

Kingyem0c0re
12-16-2006, 06:12 PM
The guitar may not be grounded properly?

The amp sounds like a dodgey wire or something?

BichGoat
12-16-2006, 06:19 PM
hmm messed up jacklead or output jack, i had this problem, if your certian u can fix it and your sure its the output jack on the guitar send it off to be fixed otherwise try soldering the conenctions at your own risk

DIY style :D

lexhibit
12-16-2006, 06:22 PM
Hey guys, just bought my second guitar, which is also my first electric. I was on a budget, so I had to buy a lower-end model. It's an Aria STG Series, and the amp is a Groove Factory GF-10G. The guitar is pretty good for the price.

But, my amp crackles a lot when i turn it on, but then it stops after about 3 or 4 minutes. This happens regardless of whether my guitar, or even the cable, is plugged in or not.

Also, it hums when i turn it up to around 8 or 9, but that's probably normal. But when I touch the strings, the boost switch or the screws around the pickups and the switches, it reduces considerably (although its still there), sort of like a 'channel' of humming got switched off.

Could anyone help me with this, please? Is this normal, or should I go and return the amp and get another one of the same make?

Cheers :)

Cracking is NOT normal. Is the GF-10 a tube amp or Solid State? If it's tubes, A bad tube will definately cause the crackling niose, while the amp is warming up.

monarch
12-16-2006, 06:37 PM
The guitar may not be grounded properly?

The amp sounds like a dodgey wire or something?


Yeah the amp sounds like there's a lose connection, like a hiss/hum sound.


hmm messed up jacklead or output jack, i had this problem, if your certian u can fix it and your sure its the output jack on the guitar send it off to be fixed otherwise try soldering the conenctions at your own risk

DIY style


No, I have no tools at home, and I'm not sure I want to mess around with it, lol.


Cracking is NOT normal. Is the GF-10 a tube amp or Solid State? If it's tubes, A bad tube will definately cause the crackling niose, while the amp is warming up.


I'm not sure... how/where do I check this?

There are no gain or shift dials, it only has volume, bass, treble and mid. And there's an overdrive switch with no dial for gain, so all it does is give out undesirable and unusable amounts of distortion. There's also an out for headphones which turns the amp off when you plug a wire into it.

I searched for some info on Google, and a reviewer mentioned that it's a transistor amp.

monarch
12-16-2006, 07:02 PM
Also, I just checked the soldering. I read somewhere that if the soldering isn't perfectly smooth, then its been soldered badly.. is that true? Because that's the case with this amp.

lexhibit
12-16-2006, 07:08 PM
Also, I just checked the soldering. I read somewhere that if the soldering isn't perfectly smooth, then its been soldered badly.. is that true? Because that's the case with this amp.
If it's not the guitar cord, etc, return the amp, if it's not too late, DO NOT try to fix it yourself, you can get seriously Zapped or killed if you don't know what you're doing in there, it may be a factory lemon, I bought a top of the line Hughes & Kettner last year and had the same problems you're having, unfortunately it's not that unusual these days to get a bad amp out of the factory.

monarch
12-16-2006, 07:53 PM
Alright, I've decided to return the amp and get a replacement on Monday. Thank you to those who answered my questions, you guys helped a lot :)