Go Back   UG Community @ Ultimate-Guitar.Com > Music > Recording
User Name  

Old 07-04-2014, 01:41 PM   #1
Registered User
Join Date: Mar 2014
Did I break the top of my sm57?

So I was using my SM57 the other day and I took the top off. I can't put it back together. Not sure if I broke it, or if I just don't know how to put the top together. Here's a pic. Thanks in advance.
Attached Images
stephan.jimenez is offline   Reply With Quote
Old 07-04-2014, 03:28 PM   #2
PSimonR's Avatar
Join Date: Nov 2010
Location: Derby, UK
So, it should go back together

Here is a link to some links that should help


"You can actually remove the sticker around the windscreen and expose the holes so you can pinch the clip and remove the screen."

So somehow you have to get the wire clip back into its groove having put the bits together in the right order.



Last edited by PSimonR : 07-04-2014 at 03:44 PM.
PSimonR is offline   Reply With Quote
Old 07-08-2014, 06:58 PM   #3
Futile Bread Machine
oneblackened's Avatar
Join Date: Oct 2007
Simon is right.

But... I just have to ask, why did you take it apart?
Current Gear:
LTD MH-400 (BKP Nailbomb/VHII)
LTD MH-400NT (EMG 81/85)
ESP Horizon NT-7 (SD Full Shreds)
UA Apollo Twin Duo
Peavey Revalver 4

I'm a recording engineer. If you have questions or you want some work done, message me.
oneblackened is online now   Reply With Quote

Thread Tools Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:02 AM.

Forum Archives / About / TOS / Advertise with us / Customer Support / Ultimate-Guitar.Com © 2015
Powered by: vBulletin Version 3.0.9
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.