Go Back   UG Community @ Ultimate-Guitar.Com > Instruments > Gear Building & Customizing
User Name  
Password
Search:

Reply
Old 12-02-2012, 04:49 AM   #1
Waylanderau
Thread Killer
 
Waylanderau's Avatar
 
Join Date: Aug 2008
Location: Logan, Australia
Marshall amp technical question...

Hey all. I just picked up a non-functioning Marshall Mode Four head off the 'bay for $100. The previous owner reckons the output transistors are fried and a bit of research revealed that this quite likely and is a fairly common problem in this model. Not that much of a big deal; I've lined up a tech to fix it, but my concern is that according to what I've read if it happens once it's likely to happen again. Is anyone aware of any mods or other methods that I could employ to try and minimise the risk?I'm told that it's generally the result of overheating and your best bet is to make sure the inbuilt cooling fans stay clean and functioning but any other suggestions would be much appreciated.
__________________
Like melodic, groovy metal? Check out my band Trinatyde on facebook and reverbnation:

http://www.facebook.com/Trinatyde

http://www.reverbnation.com/trinatyde
Waylanderau is offline   Reply With Quote
Reply


Thread Tools Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -4. The time now is 02:45 AM.

Forum Archives / About / Terms of Use / Advertise / Contact / Ultimate-Guitar.Com © 2014
Powered by: vBulletin Version 3.0.9
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.