Go Back   UG Community @ Ultimate-Guitar.Com > Music > Recordings > Original Recordings
User Name  
Password
Search:

Reply
Old 12-10-2012, 10:20 PM   #1
archtek
Registered User
 
Join Date: Jul 2012
phase shift (preview) - c4c

Here's a track I've recently started working on. Its a dubstep track made in able ton with massive. Im really digging what I've done so far so thought I'd share it because its probably gonna change a lot by the end but wanted to capture this as it is cost it sounds so good to me. Any feedback would be great thanks.

http://soundcloud.com/psychoticmant...e-shift-preview

Last edited by archtek : 12-10-2012 at 11:25 PM.
archtek is offline   Reply With Quote
Old 12-10-2012, 11:35 PM   #2
aaron aardvark
Registered User
 
Join Date: Mar 2010
archtek,
Pretty bizarre & trippy stuff! In some ways I think it gets a bit repetitive, yet it sounds pretty unique in other ways. You'd probably like trying out Arturia Spark Dubstep for free for at least 15 days (I did recently). Please review my synth music at this link:

http://www.ultimate-guitar.com/foru...d.php?t=1576745
aaron aardvark is offline   Reply With Quote
Old 12-10-2012, 11:45 PM   #3
archtek
Registered User
 
Join Date: Jul 2012
It is really early stages with this one, and really there's only material for 1 section there I doubled it up just to make it longer. Hopefully be at least 2 other different parts. I'll check that out.
archtek is offline   Reply With Quote
Old 12-11-2012, 09:00 AM   #4
andy_h04
Registered User
 
andy_h04's Avatar
 
Join Date: Jan 2007
Location: Australia
pretty cool track dude, only suggestion is to really beef up the current kick or find a new one, the current one sounds really weak in the mix - bass would probably help too!
andy_h04 is offline   Reply With Quote
Old 12-11-2012, 11:17 AM   #5
archtek
Registered User
 
Join Date: Jul 2012
Safe for the feedback. I did layer up a sub bass, maybe I turned it off at some point, yeah I'll attend to those issues cheers :-)

edit - concerning the bass issue, looks like i fecked up and didnt set my sub to the right octave, and was changing the wrong synths settings so wasn't getting any bottom end. Good thing you pointed it out thanks dude!!!!

Last edited by archtek : 12-11-2012 at 12:13 PM.
archtek is offline   Reply With Quote
Reply


Thread Tools Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -4. The time now is 05:14 PM.

Forum Archives / About / Terms of Use / Advertise / Contact / Ultimate-Guitar.Com © 2014
Powered by: vBulletin Version 3.0.9
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.