Go Back   UG Community @ Ultimate-Guitar.Com > Music > Recordings
User Name  
Password
Search:

Reply
Old 12-11-2012, 05:48 PM   #1
Usernames sucks
Registered User
 
Usernames sucks's Avatar
 
Join Date: Jun 2010
Location: Norway
EzDrummer latency

Hi. I have noticed latency in ez drummer when i hit a key on my midi keyboard connected to ezdrummer in my daw (about 0,5 seconds). Some projects there are no latency at all and some have about a hald second, it depends if i have alot of audio items and tracks for some reason. Same latency happens if i mouse-click the drums. It is no latency with other big vsts in the same project like omnisphere. Is it normal? I want to buy an electronic drumkit and play, but it seems impossible in my situation. My interface is a Pod Ux1, and i have never had any latency problems with it with recording (i have some latency when monitoring tracks whith fx). When i check my cpu use for the project, it is very low. Does the same problem happen in superior drummer?

EDIT: I could probably mute the ezdrummer track, and record midi via the electronic kit, while using the built in drumbrain to monitor, but this would lead to some issues:
1. When recording, how do you get the sounds from both the monitored sounds from the drumset and the metronome/other instruments in the same headphones? Can you connect an aux cable from the audio interface to the aux in on the electronic kit, and hear everything frim the headphones connected to the electronic set?
2. How could you use ezdrummer live whith a e-drumset?
3. How do you record with a midi device that dosnt have built in audio?

Thanks alot if anyone would answer my questions!
__________________
Original fusion metal song:
http://m.soundcloud.com/kjartan-thorkildsen/euphoric
ORIGINAL PROGRESSIVE METAL SONG:
https://soundcloud.com/kjartan-thor...fe-in-purgatory

Last edited by Usernames sucks : 12-11-2012 at 06:29 PM.
Usernames sucks is offline   Reply With Quote
Old 12-12-2012, 12:15 AM   #2
T4D
20 guitars and counting..
 
T4D's Avatar
 
Join Date: Apr 2005
Location: Aussie in the UAE
the check the driver your using,. and it's settings
the only one i use is the ASIO ( i have a list Direct X etc etc but ASIO is recommended by everyone and all testing by far is the best on my computers )

this was reinforce when i did connected my Edrums to Ezdrummer YES I got HUGE delay from hitting drum to EZdrummer the sound ,. after some playing i found Ezdrummer standalone was using the wrong driver ,. once ASIO was in, ALL prefect
__________________
Newest Tune
Last Album Album here too
I'm a 3D Artist still making tunes Joy4D Video Joy4D Site

I got Protools, Eleven Rack & lots of other stuff.
T4D is offline   Reply With Quote
Old 12-12-2012, 01:41 AM   #3
Usernames sucks
Registered User
 
Usernames sucks's Avatar
 
Join Date: Jun 2010
Location: Norway
Well, im using the asio ux1 driver for my soundcard.
__________________
Original fusion metal song:
http://m.soundcloud.com/kjartan-thorkildsen/euphoric
ORIGINAL PROGRESSIVE METAL SONG:
https://soundcloud.com/kjartan-thor...fe-in-purgatory
Usernames sucks is offline   Reply With Quote
Old 12-12-2012, 02:48 AM   #4
T4D
20 guitars and counting..
 
T4D's Avatar
 
Join Date: Apr 2005
Location: Aussie in the UAE
what are the buffer settings ? bring them as low as you can without the sound breaking up.
__________________
Newest Tune
Last Album Album here too
I'm a 3D Artist still making tunes Joy4D Video Joy4D Site

I got Protools, Eleven Rack & lots of other stuff.
T4D is offline   Reply With Quote
Old 12-12-2012, 02:52 AM   #5
T4D
20 guitars and counting..
 
T4D's Avatar
 
Join Date: Apr 2005
Location: Aussie in the UAE
what's DAW software are you using ?

if some big projects have not issues and then you have issues in new projects I think this is more DAW issue not EZdrummer Mainly because the DAW normally take over control of the audio card and EZdrummer run inside that control.

to confirm how does standalone Ezdrummer work for you ?
__________________
Newest Tune
Last Album Album here too
I'm a 3D Artist still making tunes Joy4D Video Joy4D Site

I got Protools, Eleven Rack & lots of other stuff.
T4D is offline   Reply With Quote
Old 12-12-2012, 10:15 AM   #6
Usernames sucks
Registered User
 
Usernames sucks's Avatar
 
Join Date: Jun 2010
Location: Norway
Im using reaper, and i have set my buffer to be the best possible. I think you misunderstood me. I have issues with big projects, and not small.
__________________
Original fusion metal song:
http://m.soundcloud.com/kjartan-thorkildsen/euphoric
ORIGINAL PROGRESSIVE METAL SONG:
https://soundcloud.com/kjartan-thor...fe-in-purgatory

Last edited by Usernames sucks : 12-12-2012 at 10:59 AM.
Usernames sucks is offline   Reply With Quote
Old 12-12-2012, 11:34 AM   #7
T4D
20 guitars and counting..
 
T4D's Avatar
 
Join Date: Apr 2005
Location: Aussie in the UAE
well then i would have to guess it's more a Reaper issue and or a resource issue
what cpu , ram do you have ?

Maybe best to check the reaper forums on how much you can run in a single reaper project on your hardware .. I personally do not think it's a Ezdrummer issue, BUT when i say that Ezdrummer is Not the most efficient maybe it's pushing you over your hardware limits..
__________________
Newest Tune
Last Album Album here too
I'm a 3D Artist still making tunes Joy4D Video Joy4D Site

I got Protools, Eleven Rack & lots of other stuff.
T4D is offline   Reply With Quote
Old 12-12-2012, 12:23 PM   #8
Usernames sucks
Registered User
 
Usernames sucks's Avatar
 
Join Date: Jun 2010
Location: Norway
I tried to open ti in toontrack solo, and open it in reaper, using the asio of my pod hd500 guitar pedalboard (it can act as a soundcard), and it was still the same latency. But i dont think its an issue with reaper, since the same latency happens in toontrack solo, and its not related to reaper.
__________________
Original fusion metal song:
http://m.soundcloud.com/kjartan-thorkildsen/euphoric
ORIGINAL PROGRESSIVE METAL SONG:
https://soundcloud.com/kjartan-thor...fe-in-purgatory
Usernames sucks is offline   Reply With Quote
Old 12-12-2012, 06:16 PM   #9
AJScott
Registered User
 
AJScott's Avatar
 
Join Date: Nov 2010
I had this exact question, what is your DAW? You need to set the driver settings to ASIO, I had this issue. I'd have my Focusrite interface connected and my MIDI Pad controlling Superior Drummer but there was a noticeable delay, when I switch to the ASIO setting this practically vanished.
AJScott is offline   Reply With Quote
Old 12-12-2012, 06:27 PM   #10
Usernames sucks
Registered User
 
Usernames sucks's Avatar
 
Join Date: Jun 2010
Location: Norway
Quote:
Originally Posted by AJScott
I had this exact question, what is your DAW? You need to set the driver settings to ASIO, I had this issue. I'd have my Focusrite interface connected and my MIDI Pad controlling Superior Drummer but there was a noticeable delay, when I switch to the ASIO setting this practically vanished.

I use reaper (extremely stable) and asio driver for my soundcard (pod ux1)
__________________
Original fusion metal song:
http://m.soundcloud.com/kjartan-thorkildsen/euphoric
ORIGINAL PROGRESSIVE METAL SONG:
https://soundcloud.com/kjartan-thor...fe-in-purgatory
Usernames sucks is offline   Reply With Quote
Old 12-13-2012, 01:55 AM   #11
T4D
20 guitars and counting..
 
T4D's Avatar
 
Join Date: Apr 2005
Location: Aussie in the UAE
OK if you totally sure it is NOT a Reaper issue ,..I think it's a ASIO driver issue, I say this because afew months back i connected my edrums to SD in Protools all worked fine ,. then I added another kit,. & not being sure how to connect 2 kits,. I thought I will set up first in Standalone version ,... HUGE delay in standalone,. I'm totally confused ??

done all sorts of testings but then I when i went back into protool and set up both kits there it worked prefect ?,. NOW I had to get standalone work !!! then I check my driver setting in Standalone and BAM the ASIO driver was not set up it auto choose the DirectX driver for some reason ? chenged it and it all worked prefect..


OK checking the pod ux1 spec's i have to ask how are you getting midi into your computer it has no Midi port ?? what hardware driver is involved there ?? ( maybe the issue is that ? )


also is there a project/setup in reaper that ezdrummer does work perfectly ?
maybe start with a good ezdrummer setup and find the problem as you add things.. ?
__________________
Newest Tune
Last Album Album here too
I'm a 3D Artist still making tunes Joy4D Video Joy4D Site

I got Protools, Eleven Rack & lots of other stuff.
T4D is offline   Reply With Quote
Old 12-13-2012, 04:18 AM   #12
Usernames sucks
Registered User
 
Usernames sucks's Avatar
 
Join Date: Jun 2010
Location: Norway
I use midi via usb. I have 2 midi keybards.
__________________
Original fusion metal song:
http://m.soundcloud.com/kjartan-thorkildsen/euphoric
ORIGINAL PROGRESSIVE METAL SONG:
https://soundcloud.com/kjartan-thor...fe-in-purgatory
Usernames sucks is offline   Reply With Quote
Old 12-13-2012, 04:25 AM   #13
diabolical
Registered User
 
diabolical's Avatar
 
Join Date: Apr 2005
Location: Houston, TX
I think your best bet is submixing your project, freezing multitrack files and doing drums over smaller track/fx count.
__________________
Quote:
Originally Posted by CodeMonk
Trading an MG + $100 for a Spider is like trading dogshit for catshit and paying for the privilege.
diabolical is offline   Reply With Quote
Old 12-13-2012, 04:52 AM   #14
Usernames sucks
Registered User
 
Usernames sucks's Avatar
 
Join Date: Jun 2010
Location: Norway
Quote:
Originally Posted by diabolical
I think your best bet is submixing your project, freezing multitrack files and doing drums over smaller track/fx count.

Well, dosnt it work to mute the ezdrummer track connect usb from e-drumkit to record midi to that track, connect a aux from interface headphones to aux in on the e-kit (so you can hear the other instruments in the project, and record midi, while using the built in sounds from the kit to monitor? Does it work to record midi from a e- kit when playing and hear the normal sounds?
__________________
Original fusion metal song:
http://m.soundcloud.com/kjartan-thorkildsen/euphoric
ORIGINAL PROGRESSIVE METAL SONG:
https://soundcloud.com/kjartan-thor...fe-in-purgatory
Usernames sucks is offline   Reply With Quote
Reply


Thread Tools Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -4. The time now is 04:32 AM.

Forum Archives / About / Terms of Use / Advertise / Contact / Ultimate-Guitar.Com © 2014
Powered by: vBulletin Version 3.0.9
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.