Go Back   UG Community @ Ultimate-Guitar.Com > Instruments > Guitar Gear & Accessories
User Name  
Password
Search:

Reply
Old 05-07-2013, 10:36 AM   #1
Green_Ghoul
Registered User
 
Join Date: Aug 2010
Location: Michigan
Question roland jazz chorus 77 - making noise..?

Hey everyone, so I just bought a JC77 and it makes this fuzzy "ssssssssss" noise whenever the amp is on. I've tried turning everything down all the way and it's still there. I know that it's an older amp and everything, but what gives? Could the speaker connections be faulty? What about the speakers themselves? Or do I just have a lemon? I wanted to do a NAD but I feel that I can't until this is sorted...

Thanks
Green_Ghoul is offline   Reply With Quote
Old 05-07-2013, 10:39 AM   #2
Green_Ghoul
Registered User
 
Join Date: Aug 2010
Location: Michigan
sorry for the double post, i can't hit the edit button on my phone

anyway, it happens when nothing is plugged in, while strumming, even when pickups are turned off....the noise sounds similar to when the radio isn't on a station...just that staticky noise.
Green_Ghoul is offline   Reply With Quote
Reply


Thread Tools Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -4. The time now is 06:59 AM.

Forum Archives / About / Terms of Use / Advertise / Contact / Ultimate-Guitar.Com © 2014
Powered by: vBulletin Version 3.0.9
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.