Go Back   UG Community @ Ultimate-Guitar.Com > Instruments > Guitar Gear & Accessories
User Name  
Password
Search:

Reply
Old 01-25-2013, 12:43 AM   #1
Paroxysm
Registered User
 
Join Date: May 2004
Location: Broomfield, Colorado
Ampeg VH140C popping sound

So I just recently purchased the VH140C combo from a local pawn shop after talking the price down to $100. The amp works fine when I tested at the shop (about an hour of playing) and for several days at home. Today I heard a loud popping sound when I turn it on and constant humming and buzzing even wih the guitar volume down. When I start playing sometimes the loud popping will come up again. Just for those who own the amp or had one before, is this something expected of this amp? This my first solid state so I dont really know what the problem could aside from some soldering or wire issues maybe.
__________________
Class of 2007
Paroxysm is offline   Reply With Quote
Old 01-25-2013, 10:49 PM   #2
311ZOSOVHJH
G G & A - B A B Y
 
311ZOSOVHJH's Avatar
 
Join Date: Mar 2008
Location: Offline
free bump day

kinda surprised no one offered to give you a hand

I would check the guitar insert jack connections and speaker connections first and then report back. Hopefully it is something simple like that. A connection somewhere.
__________________
311ZOSOVHJH is offline   Reply With Quote
Old 01-26-2013, 01:18 AM   #3
DeathByDestroyr
not autistic
 
DeathByDestroyr's Avatar
 
Join Date: Oct 2008
Location: Minnesota
I would think it would be a grounding problem or something...



Bumped!
DeathByDestroyr is offline   Reply With Quote
Old 01-26-2013, 02:29 AM   #4
Offworld92
One among the fence.
 
Offworld92's Avatar
 
Join Date: Nov 2009
Location: Southern California, USA
Quote:
Originally Posted by 311ZOSOVHJH
free bump day

kinda surprised no one offered to give you a hand

I would check the guitar insert jack connections and speaker connections first and then report back. Hopefully it is something simple like that. A connection somewhere.


To be fair SS amps are kind of no-man's land. Can't just say replace a preamp tube.
__________________
Spin 'round carousel when your horse isn't screwed in.

Epiphone Firebird VII
Ibanez S420
LTD H-301
Peavey Predator USA
Ibanez RG520
Line 6 Pod HD500X
VHT Special 6 Ultra
Pedulz
Offworld92 is online now   Reply With Quote
Old 01-26-2013, 03:23 AM   #5
Paroxysm
Registered User
 
Join Date: May 2004
Location: Broomfield, Colorado
Took it to a locaal amp repair shop today (took a while to find the one that will even check solid state amps). Not an input jack or grounding issue, I checked those. Guess I will find out over the weekend. Good amp when it was working
__________________
Class of 2007
Paroxysm is offline   Reply With Quote
Old 01-26-2013, 12:16 PM   #6
311ZOSOVHJH
G G & A - B A B Y
 
311ZOSOVHJH's Avatar
 
Join Date: Mar 2008
Location: Offline
^ well good luck

I'd be curious to hear what it is.


Quote:
Originally Posted by Offworld92
To be fair SS amps are kind of no-man's land. Can't just say replace a preamp tube.

True.

But I don't necessarily think of popping sounds when I think about bad preamp tubes anyway. I think of dodgy connections going hot and cold which could happen on any amp. I was mainly just giving the guy a free bump.
__________________

Last edited by 311ZOSOVHJH : 01-26-2013 at 12:18 PM.
311ZOSOVHJH is offline   Reply With Quote
Old 01-26-2013, 12:36 PM   #7
DeathByDestroyr
not autistic
 
DeathByDestroyr's Avatar
 
Join Date: Oct 2008
Location: Minnesota
TBH, my Ampeg SS pops as well, has been for years. It doesn't hum and buzz though.



Unless you consider my tone a buzz..........

=/
DeathByDestroyr is offline   Reply With Quote
Old 01-26-2013, 01:08 PM   #8
Offworld92
One among the fence.
 
Offworld92's Avatar
 
Join Date: Nov 2009
Location: Southern California, USA
Quote:
Originally Posted by 311ZOSOVHJH
True.

But I don't necessarily think of popping sounds when I think about bad preamp tubes anyway. I think of dodgy connections going hot and cold which could happen on any amp. I was mainly just giving the guy a free bump.


True and ditto.
__________________
Spin 'round carousel when your horse isn't screwed in.

Epiphone Firebird VII
Ibanez S420
LTD H-301
Peavey Predator USA
Ibanez RG520
Line 6 Pod HD500X
VHT Special 6 Ultra
Pedulz
Offworld92 is online now   Reply With Quote
Reply


Thread Tools Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -4. The time now is 04:47 PM.

Forum Archives / About / Terms of Use / Advertise / Contact / Ultimate-Guitar.Com © 2014
Powered by: vBulletin Version 3.0.9
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.