Go Back   UG Community @ Ultimate-Guitar.Com > Instruments > Bass Guitar
User Name  

Old 08-09-2013, 04:09 AM   #1
Registered User
Join Date: Oct 2010
Quick question regarding Warwick head

Is it detrimental to the head at all to run it without a cab and instead use the headphone out? I've heard various conflicting stories about this and was holing someone could clarify. It's a WA300 solid state if that helps.
AxolotlShredder is online now   Reply With Quote
Old 08-09-2013, 04:19 AM   #2
The Enigma
Ziphoblat's Avatar
Join Date: Jun 2010
Location: Purgatory
Powering up an amplifier with no load is only dangerous for valve heads to my knowledge. You should be fine.
Save a Cow,
Eat a Vegan.
Ziphoblat is offline   Reply With Quote
Old 08-10-2013, 06:32 AM   #3
Nutter_101's Avatar
Join Date: Aug 2006
Location: London, Scotland, or Cornwall.
Ziphoblat answered your question, I just wanted to ask what you think of the WA300 head? Haven't seen many reviews go up about them yet!
In the bass chat:

<Jon> take the quote of me out your sig plx
<Jon> i hate seeing what i said around lol

Leader of the Bass Militia PM to join!

And now on BANDCAMP!

Officially the funniest member of the Bass Forum.
Nutter_101 is offline   Reply With Quote
Old 08-13-2013, 07:27 AM   #4
Registered User
Join Date: Oct 2010
Cheers Ziphoblat, that helps a lot.

@Nutter, it's a pretty solid head for the price, although I haven't really had a chance to run it in a band setting yet.
AxolotlShredder is online now   Reply With Quote

Thread Tools Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 02:51 AM.

Forum Archives / About / TOS / Advertise with us / Customer Support / Ultimate-Guitar.Com © 2015
Powered by: vBulletin Version 3.0.9
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.