adalabonamah
Registered User
Join date: Oct 2012
10 IQ
#1
My amp crackled then started letting out a decently loud hum. I took a look at the back and one of the tubes was sparking. I assumed I just needed to replace the power tubes, so I did, but after looking closer it appears red smoke was bleeding out of the tube socket. My guess would be to take the chasis out and see if there is a pin or something out of sort.

Anyone have a recommendation of how to troubleshoot the issue? I don't have experience fiddling around with this stuff and will take it in if I have to, but would like to see what can be done beforehand.

Thanks!
Roc8995
Moderator
Join date: Nov 2005
250 IQ
#2
Take it in. This sounds like an issue too serious for you to learn as you go. A tube amp can injure you quite badly if you don't know what you're doing, especially if you're poking around the (damaged) power tube sockets.
R45VT
Doesn't speak guitar
Join date: Dec 2009
110 IQ
#3
So you have smoke with new power tubes?

Ouch.


You can do a visual inspection and look for overheated components such as the PCB, resistors, etc.

You can always post pics and we would help

Just be forewarned- lethal voltages are present inside of your amp. If you are not comfortable with that then take it in. No need to die over it.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
Last edited by R45VT at Nov 29, 2012,
R45VT
Doesn't speak guitar
Join date: Dec 2009
110 IQ
#5
Wow.

Talk about letting the smoke out.

Yeah, take it to a shop. Bummer. Thanks for the video.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.