#1
Hey guys, I just bought my first tube amp. I picked up a Mesa Boogie Rectorverb series 2 and love it, but I am having a slight problem. I am having trouble getting gain/distortion from it. I am playing an ESP LTD EC-1000 with an EMG 81/60 configuration and can't get any distortion. Most people I've talked to said I should get plenty of distortion with the gain set at 12:00, but it is more like a soft crunch. To get a good distortion sound, I have to crank the gain almost all the way to max.
Here are my settings

Gain - ~3:30
Treble - 2:00
Mid - 11:00
Bass - 12:30
Pres - 11:00
Master - 12:00

I have been playing at lower volumes, but when I do turn it up, there is some distortion, but not a lot at my settings. I think I might have to replace the preamp tubes. I am not quite sure how old this amp is and if the previous owner/owners ever replaced them. All the preamp tubes are the stock Mesa 12AX7A's if that helps anything. Should I get new preamp tubes? Thanks!
#2
I have the gain nearly maxed on my mark V. It's normal for that amp. Not sure on yours.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
#3
From what people have told me, I should not have to max out my gain. It is a single rectifier.
#4
you're on the lead channel right?
sounds like it might be tubes.
buffalo buffalo buffalo buffalo buffalo buffalo buffalo.
#7
Quote by Blktiger0
Which Channel are you using?

I would say it wouldn't hurt to do a full retube if you bought it used. I would put new preamp tubes AND new Power Tubes in it.


Its worth mentioning Mesa Boogies are fixed non-adjustable bias. Plug and play for the power tubes.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
#8
Quote by AcousticMirror
you're on the lead channel right?
sounds like it might be tubes.


Ya, I am on the lead/dirty channel with the modern setting on. I will try cranking it up tonight and see if that's the problem. If not, what are some good high gain preamp tubes?
#9
Quote by masonb09
Ya, I am on the lead/dirty channel with the modern setting on. I will try cranking it up tonight and see if that's the problem. If not, what are some good high gain preamp tubes?


JJs are great for the money. Tungsols are a bit thin, however can brighten a dark amp.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
#10
Thanks! I don't think my preamp tubes have ever been changed. I emailed Mesa Boogie and my amp is 10 years old so I think changing them could help tremendously.