theonecalledjoe
Registered User
Join date: Jun 2008
631 IQ
#1
Hey guys.

After 2 years by beloved Blackheart Little Giant head has died.
Basically I had just finished up in the studio 2 days ago with my band (Bunderthird)
I went to turn the head back on 1 more time before i left to test out a cabnet and the head wouldn't power on. The light didn't turn on nor did it make any sound.

I looked in the back of the amp and noticed scorch marks on the power amp tube. (El84.)
So I'm assuming the power amp tube died? I bought the amp second hand and don't know how old the tubes are.
Or is it something different?
My friend who is doing the recording for us said i might have blown a fuse though. Is that the case? I have no idea how to really troubleshoot since this was my first tube amp.

If it is the tubes. Should i just replace them and be good to go?
and how would i go about doing that? What kinda tubes? etc.
Like if I were to buy another EL84. sayyyy a JJ or a EHX. Can i just put it right in myself? or do i have to take it to a shop?
Same with the preamp tube. (If i'm going to do a tube swap. I'm going to do both)

sorry for all the questions. Thanks ahead of time
Fender Telecaster
Squier Jazzmaster
Fender Deluxe Stratocaster
Hagstrom F-301
Epiphone Dot

Big Muff Pi
Small Clone
MXR Phase 90
Dunlop CFH
Crate V33H>Bugera2x12

Bunderthird (Alt Rock)
www.facebook.com/bunderthird
Eppicurt
Don't even like pedals.
Join date: Aug 2008
2,594 IQ
#2
If it's not powering on, sounds like a fuse.

New tubes would probably be an idea. Got any photos of the current tubes?
Quote by SimplyBen
That's the advantage of being such a distance from Yianni. I can continue to live my life without fear of stumbling upon his dark terror.


Quote by Toppscore
NakedInTheRain aka "Naked with shriveled pencil sized bacon In The Rain"
theonecalledjoe
Registered User
Join date: Jun 2008
631 IQ
#3
Not right now. But i can get some up soon. I'll probably take the chassis apart tomorrow.
Fender Telecaster
Squier Jazzmaster
Fender Deluxe Stratocaster
Hagstrom F-301
Epiphone Dot

Big Muff Pi
Small Clone
MXR Phase 90
Dunlop CFH
Crate V33H>Bugera2x12

Bunderthird (Alt Rock)
www.facebook.com/bunderthird
R45VT
Doesn't speak guitar
Join date: Dec 2009
1,110 IQ
#4
Quote by Eppicurt
If it's not powering on, sounds like a fuse.

New tubes would probably be an idea. Got any photos of the current tubes?


x2. Sounds like the tube went bad and blew the fuse.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
rocknroll93
Warning: Small Parts
Join date: Nov 2007
501 IQ
#5
Quote by R45VT
x2. Sounds like the tube went bad and blew the fuse.


this.
Quote by element4433
One time I watched a dog lick his own dick for twenty minutes.

Quote by Roc8995
No.


Well, technically it could be done, but only in the same way that you could change a cat into a hamburger. It's an unpleasant process, and nobody is happy with the result.
theonecalledjoe
Registered User
Join date: Jun 2008
631 IQ
#6
oh. that sounds scary. Should i just take it into a shop and get it looked at?

or is this a repair i can do myself?
(I'm a complete n00b when it comes to this kinda stuff)
Fender Telecaster
Squier Jazzmaster
Fender Deluxe Stratocaster
Hagstrom F-301
Epiphone Dot

Big Muff Pi
Small Clone
MXR Phase 90
Dunlop CFH
Crate V33H>Bugera2x12

Bunderthird (Alt Rock)
www.facebook.com/bunderthird
theonecalledjoe
Registered User
Join date: Jun 2008
631 IQ
#7
also i believe the tubes are stock (and the amp was made in 2007). Which probably explains them blowing. I had been running that amp pretty hard all day, and that past week recording.
Fender Telecaster
Squier Jazzmaster
Fender Deluxe Stratocaster
Hagstrom F-301
Epiphone Dot

Big Muff Pi
Small Clone
MXR Phase 90
Dunlop CFH
Crate V33H>Bugera2x12

Bunderthird (Alt Rock)
www.facebook.com/bunderthird
R45VT
Doesn't speak guitar
Join date: Dec 2009
1,110 IQ
#8
Quote by theonecalledjoe
oh. that sounds scary. Should i just take it into a shop and get it looked at?

or is this a repair i can do myself?
(I'm a complete n00b when it comes to this kinda stuff)


Replace the tube and the fuse. Make sure it isn't plugged in and you are set to change the tube and fuse.
Quote by DeathByDestroyr
See, it's important that people clarify when they say "metal", because I pretty much always assume they are a Cannibal Corpse fanboi.
theonecalledjoe
Registered User
Join date: Jun 2008
631 IQ
#9
So if i just buy another EL84 and a 250v fuse i should be good to go?
Fender Telecaster
Squier Jazzmaster
Fender Deluxe Stratocaster
Hagstrom F-301
Epiphone Dot

Big Muff Pi
Small Clone
MXR Phase 90
Dunlop CFH
Crate V33H>Bugera2x12

Bunderthird (Alt Rock)
www.facebook.com/bunderthird
theonecalledjoe
Registered User
Join date: Jun 2008
631 IQ
#10
ok yeah. I took the tube out and its shot.
If I replace the EL84 and the 12AX7 with new tubes of the same type, to i have to get the amp re-biased?
Fender Telecaster
Squier Jazzmaster
Fender Deluxe Stratocaster
Hagstrom F-301
Epiphone Dot

Big Muff Pi
Small Clone
MXR Phase 90
Dunlop CFH
Crate V33H>Bugera2x12

Bunderthird (Alt Rock)
www.facebook.com/bunderthird