#1
Hey, I have a strange sound issue on my Blackstar HT5C. I just changed the tubes, hoping that it would disappear, but nothing has changed.

I can hear a noise on the clean channel, as well as the dirty channel with low gain. It sounds like some kind of buzz or hum that overlaps with the guitar sound when I play, like another layer of sound. There's nothing when I don't play, I can only hear it faintly over the sound of the guitar. Actually, it resembles the sound of a distorted guitar at a very, very low volume. It's rather discreet, you cannot hear it when there is a lot of gain on the dirty channel, but it's really noticeable and annoying with cleaner sounds. There's no noise in the headphones input, however.

I recorded it with my phone, but apparently I can't post a link to the sound file on this forum. Too bad!

Does anybody know what could cause this? Is it fixable?
#2
Did you blow your speaker?
"If you're looking for me,
you better check under the sea,
because that's where you'll find me..."
#3
Same thing is happening to my HT5H but ive got a constant buzzing...
I shouldn't post when drunk..



07 LTD MH400NT SD SH2/SH5
15 Jackson SLATHX-m 3-7 Slime green
Squier std tele (modded to hell)

Engl Powerball
Laney Ironheart 60h
Zilla Superfatboy 2x12 v30's

Pedals
#5
Carrot, constant buzzing and no buzz on the headphones could be failing power supply filter caps on the high voltage.
#6
Quote by fly135
Carrot, constant buzzing and no buzz on the headphones could be failing power supply filter caps on the high voltage.



So basically its past its BBE date then?
I shouldn't post when drunk..



07 LTD MH400NT SD SH2/SH5
15 Jackson SLATHX-m 3-7 Slime green
Squier std tele (modded to hell)

Engl Powerball
Laney Ironheart 60h
Zilla Superfatboy 2x12 v30's

Pedals