Page 2 of 2
#41
Operator error.
Gilchrist custom
Yamaha SBG500
Telecasters
Randall RM100 & RM20
Marshall JTM45 clone
Marshall JCM900 4102 (modded)
Marshall 18W clone
Fender 5F1 Champ clone
Atomic Amplifire
Marshall 1960A
Boss GT-100


Cathbard Amplification
My band
#42
Quote by MistaChy
I went and tested a deluxe reverb today. the issue is there is no controlling when it breaks up. i have to hit certain levels in volume before its too loud to really enjoy some mellow crunch. with the ac30, i just turn up the channel volume and lower the gain and im crunchin' like captain crunch.


See if you can find and try out a Fender Blues Deluxe RI.
Spin 'round carousel when your horse isn't screwed in.

My band:
Fractured Instinct
(For fans of Death/Groove/Prog Metal)

Ibanez RGA42E
Ibanez S420
LTD H-301
Ibanez RG520
Peavey Predator USA
Douglas Grendel 725
Line 6 Pod HD500X
#43
Try sticking an EQ with volume sliders (like the MXR 10 band) or a volume pedal, in the loop.
"If you're looking for me,
you better check under the sea,
because that's where you'll find me..."
#44
Quote by MistaChy
I went and tested a deluxe reverb today. the issue is there is no controlling when it breaks up. i have to hit certain levels in volume before its too loud to really enjoy some mellow crunch. with the ac30, i just turn up the channel volume and lower the gain and im crunchin' like captain crunch.



yeah....try an EQ pedal as mentioned or an OD pedal out front.

shouldn't be an issue.

or....go try some of those other amps


every amp, guitar, guitar player, playing style, pedal, room, environment, etc is different and even then....it changes all the time. you just got to roll wit it.
Page 2 of 2