#1
I recorded 2 guitar tracks separately from each other that I played guitar while listening to the backing track and it sounded in sync for each guitar part individually while listening to them on my real time monitors, and then when I play the 2 guitar tracks at the same time in Sony Vegas Pro 10 they are out of sync!

The best result i found is saying that even though it sounded in sync when listening with headphones while playing guitar, it was recorded out of sync because the headphones are live monitors bypassing the ADC and CPU and the time to go through the ADC and the CPU creates lag.

is this why it is occuring?

what is a solution?

As a reference, here is the out of sync 2 guitar tracks: http://www.youtube.com/watch?v=MhV7MS2YJyo

I recorded them in Audacity and put the tracks together in Sony Vegas Pro 10.


Do effects have anything to do with latency in Sony Vegas Pro 10?

Like if the 2 guitar tracks have compressor applied and the backing track has no effects applied will that progressively cause the 2 guitar tracks to be out of sync with the backing track because of lag from computing the compressor effect?


Also, do different sample rates on different tracks have anything to do with becoming out of sync?

The sample rates of the 2 guitar tracks were both 48khz, which is the sample rate used by the ASIO driver of my M-Audio interface when it is used by Sony Vegas Pro 10. The sample rate of the backing track was 44.1 khz as it was ripped from a CD.

Would converting the backing track to 48khz sample rate do anything?


Well actually, in Audacity I have the sample rate at 44.1 khz, but when I load Sony Vegas Pro 10 it says something like"The M-Audio ASIO driver sample rate is not supported. 48khz will be used."

I'm not sure what this even means, I'm a total noob at recording.

Does it mean that Vegas does not support the sample rate of the interface, so it messes things up?

When I have used Pro Tools before it didn't give that error code at start up. So should I render the audio portion in Pro Tools before adding to the video portion in Vegas?
Last edited by dietermoreno at Jul 24, 2013,
#2
uhhh. I don't feel like reading that wall of text, but the problem of being out of sync is a latency problem. See, when you record something, it takes 'x' amount of time to send your output signal (from your amp, pedalboard, really whatever you're using) signal through the cords, interface, more cords, into your computer, and then be processed in your DAW.

So to fix it: Most programs have an option to fix the latency, so that's one option. Basically what it does is automatically move your track over by a predetermined amount so that you don't have to manually move it.

What I do (because I use multiple techniques of recording and don't want to adjust latency in my options all the time) is just move the guitar track over so that they're in sync. Try zooming in so that your looking at a grid broken up into 1/516ths or 1/1032nds (I think those numbers are correct) of a note per line and moving the track over ever so slightly to the left until it matches up perfectly.
Last edited by mjones1992 at Jul 24, 2013,
#3
Quote by mjones1992

What I do (because I use multiple techniques of recording and don't want to adjust latency in my options all the time) is just move the guitar track over so that they're in sync. Try zooming in so that your looking at a grid broken up into 1/516ths or 1/1032nds (I think those numbers are correct) of a note per line and moving the track over ever so slightly to the left until it matches up perfectly.

Yeah, do that. Just fix it in post, and make sure the sample rates line up.
#4
problem solved! the bit depth was too high and the sample rate was too high that was incompatible with the interface and Pro Tools. lowered bit depth to 16 bit from 32 bit and lowered sample rate from 48khz to 44.1khz and problem solved.
#5
Quote by dietermoreno
problem solved! the bit depth was too high and the sample rate was too high that was incompatible with the interface and Pro Tools. lowered bit depth to 16 bit from 32 bit and lowered sample rate from 48khz to 44.1khz and problem solved.

I'd consider trying 24 bit if it's compatible with that, I find the extra headroom is really worth it.
#6
sounds like a latency issue. try changing your buffer setting
Audio Ecstasy Productions!

Guitar/Backline Tech in the Los Angeles area and on tour!
Custom guitar pedals and cabling for stage and studio!

I set up DAWs and tweak computers to record audio. Hit me up @ audioecstasyproductions[at}gmail.com