#1
ok im using sonar 4 and a casio ctk 496 which can be connected through midi and it work but i cant turn off the internal sounds on the keyboard, so when i lay down a drum beat i hear the drums and a keyboard sound but once im done recording it i play back and i just hear the drums, also as i play it back all the sounds that are midi come out through the keyboard which is also annoying. HELP PLEASE I NEED TO LAYDOWN SOME TRACKS
#2
have you tried just turning the volume off on the keyboard?
Checked the manual?

no idea really, I'm just guessing.

-Ryan
#3
Go into your midi global settings on the keyboard and look for a setting called Local Control and turn it off.

http://www.indiana.edu/~emusic/361/localcontrol.htm

I'm pretty sure that sounds like your problem.

CT
Could I get some more talent in the monitors, please?

I know it sounds crazy, but try to learn to inhale your voice. www.thebelcantotechnique.com

Chris is the king of relating music things to other objects in real life.