#1
hey guys,

so i was playing i'm alright by neil zaza and when i switched to the bridge pickup on my behringer "metalien" (i know its a pretty crap guitar but its the only one that has 24 that i have so lay off the "that axe sucks, better off getting a new one", please, thanks) so like i said, i switched and the pickup selector switch got stuck..i managed to get it in but the tone sounded a bit weird...i blew in the pickup selector slot and everything was fine...


i continued to play the song when the tone started fading, i switched pickups to see, and sure enough the bridge pickup was fading i blew in the slot again and it went back to regular volume but the tone was still off...

i looked in the slot and found a bit of rust but nothing major, so i unplugged cuz this was REALLY pissing me off. i played around when a heard a buzzing....i didnt know what it was...i hit any note on any string and i heard a fairly loud buzz from inside the pickguard...when i turn the guitar over and do a small shake i hear nothing, but when its right side up, and shake it the buzzing starts again...


the neck pickup is fine and so is the middle. i just would like to know whats wrong and how muchits goign to cost to fix it.
ಠ_ಠ
- Yes, My name is actually Terran -
- Not just a Starcraft fan -


Terran > Zerg and Protoss
#3
i did, i took the pickguard of and everything seemed fine, no wires were off or broken. thanks for the help though.
ಠ_ಠ
- Yes, My name is actually Terran -
- Not just a Starcraft fan -


Terran > Zerg and Protoss
#4
anyone?
ಠ_ಠ
- Yes, My name is actually Terran -
- Not just a Starcraft fan -


Terran > Zerg and Protoss