#1
Okay, may be my fault, but my Firefox isn't starting at all. I've tried removing and re-installing it, system restore, looking up firefox forums and everything I could think of to no avail, and now trying to remove it from the control panel doesn't do anything.

Never had any trouble with it before. I'm using Vista Home Premium.

Box of chocolates and a special mystery surprise box to anyone who can help me with this.


Mozilla can make a browser work well, but their forums are absolutely retarded.
And using IE is like slowly sitting on a sword.
#3
Quote by Nevermind1299
If you don't like IE use Opera until you get firefox working


Thanks but no thanks.


I need to get this working.

Logically, deleting and uninstalling everything related to FF and installing it on a clean table would work, but how do I do this, since the traditional control panel uninstall doesn't work?
#4
Well, sir.. if you don't have anything important on your computer just wipe your HDD if you need firefox so bad.

And, if you do have important things just back them up on CD
#5
i had this problem once, try removing your user profile and then see if it starts up.
#6
make sure any registry entries for firefox are gone as well. Also, what did you do before it stopped working?
#8
Quote by BlackBodom
i had this problem once, try removing your user profile and then see if it starts up.


It doesn't start on other user profiles either.

Wtf is wrong with it?

Quote by 100%guitarmad
Restart your computer!

Worked for me.


Tried that a couple dozen times.

Quote by MCone
make sure any registry entries for firefox are gone as well. Also, what did you do before it stopped working?


I guess I was changing themes. But the problem isn't theme/plugin related, because it doesn't even run in Firefox Safe Mode, which disables plugins and themes.

EDIT: Oh, and it bitched something about xul.dll earlier, and google finds mozilla forum threads about that, but I can't access them.
Last edited by Tommy[fin] at Dec 25, 2008,
#9
Are you sure you haven't just bogged the browser down completely with unused add-ons?

In my experience, the more add-ons Firefox has, the longer it takes to load/start up.

If this is the case, you might just have to wait a while while it loads up, and then remove the stuff you don't use.
#10
Quote by soulflyV
Are you sure you haven't just bogged the browser down completely with unused add-ons?

In my experience, the more add-ons Firefox has, the longer it takes to load/start up.

If this is the case, you might just have to wait a while while it loads up, and then remove the stuff you don't use.


No mate, this was something unexplicable.

I fiddled around and managed to find the firefox profile, deleted everything there, in the program files and the registry, downloaded a new installer, and now it works!

*dance of win* A shame I lost all my bookmarks though, should've backed them up from the profile folder. *facepalm*
#11
[quote="'Tommy[fin"]']No mate, this was something unexplicable.

I fiddled around and managed to find the firefox profile, deleted everything there, in the program files and the registry, downloaded a new installer, and now it works!

*dance of win* A shame I lost all my bookmarks though, should've backed them up from the profile folder. *facepalm*

Oh well. At least you solved it!