#1
okay so i got a peavey valveking 100 halfstack for christmas. ive never had a tube amp before and i cant figure out how to hook it up. ive got the cable in the first going into the back of the top cabnet but i dont understand how to use the standby and power switches. can someone please help this is depressing i cant get my prestent to work???
#6
if there is a standby switch flip it on. first check your settings though, make sure your not gonna kill your amp turning it on. if it works, well there you go. if the cables confuse you, it's like any half stack. head connects to your cab
#7
look on the peavey website
Actually called Mark!

Quote by TNfootballfan62
People with a duck for their avatar always give good advice.

...it's a seagull

Quote by Dave_Mc
i wanna see a clip of a recto buying some groceries.


stuffmycatswatchontv.tumblr.com
#9
i just think the head is shot because nothing is comeing on after i flip the power is the led suppose to come on when on stanby while the tubes are heating up?
#12
Quote by Reckd
so you have them both down when amp is off then you flip them up?

No.

You have them both off,

You turn the power switch on to turn the power on and start warming the tubes.

After a couple of minutes you turn the standby switch on to turn the rest of the amp on.
Actually called Mark!

Quote by TNfootballfan62
People with a duck for their avatar always give good advice.

...it's a seagull

Quote by Dave_Mc
i wanna see a clip of a recto buying some groceries.


stuffmycatswatchontv.tumblr.com
#14
is it plugged in all the way

look where the 3pin plug goes into the head sometimes that gets loose

07 Fender American Deluxe Strat
07 Fender Custom Telecaster
09 Seymour Duncan Pickup Booster
09 Fulltone OCD V.4
10 Ibanez WH-10 V.2
09 Splawn SuperStock
10 Jet City JCA-20
97 Fender Hot Rod Deluxe

Yeh the SICK! bit sounds a bit stupid.

#17
yes matched ohms
amp lights not comeing on
yes volume is up
tubes stay the same no heat
and i pushed the power chord in as far as it would go and held it there while i tried to heat them up didnt work
o well im getting a new head tomorrow i think thats the problem how can you tell if the cabs screwed 2?
#18
Did you turn the head on without the cab connected at any point?
Epiphone G-400
GFS Crunchy PAF - Bridge

DigiTech Bad Monkey
iSP Decimator

New Amp Fund: Depleted