#1
I have a Les Paul outputting to a Digitech RP250 and then inputting into my PC. I'm using my computer's sound card (Realtek HD audio). I'm running Fruity Loops software and running ASIO4ALL. Here's the problem.

Let's say I use the headphone output of my RP250 and input it into my line-in on my PC's sound card. If I pick up my guitar and start playing, I can hear the audio from my PC speakers. Then, I load up FL and select "Line 1" as my line in and line out as my audio output on master. Now when I play my guitar the output is doubled and distorted because i'm hearing the pass-thru as well as the output from FL. So, when I apply VST effects I can't monitor them correctly because i'm also hearing the original as well. Hope this makes sense.

or...

If I output the audio from the RP250 to my PC via USB cable (which gives better audio quality IMO) I can't get any output at all to monitor. There is no pass-thru and I can't get FL to use the USB-In AND LINE-OUT at the same time.

I'm assuming this would be an issue in any sound editor i.e. Cubase. Any help would be appreciated.
#3
Hah, this is weird because whenever I record bass into FL by plugging my bass straight in, I never have this problem; I can monitor it and record just fine. That said, for some reason my active bass doesn't put a signal through, but I may need to run through a pre-amp anyway so no biggie.

Try looking through the options, but my personal experience would suggest looking at the volume controls for all the channels and make sure you're not recording onto more than one channel at once with the same instrument. I made that mistake once, and I think it was part of some default settings so it's likely it's happening to you as well.
#4
Quote by Survivalism
You know, there's an entire forum dedicated to this kind of stuff.


Sorry, I must have passed right over the audio recording and/or computer hardware/software forums.

And, I am not inputting two instruments at once. Just the once channel.
#5
Quote by krazybartender
Sorry, I must have passed right over the audio recording and/or computer hardware/software forums.

And, I am not inputting two instruments at once. Just the once channel.

No, I'm not talking about recording two instruments at once, I'm talking about having one instrument lining in but having the computer recording the one signal onto two recording channels, therefore increasing gain on that channel.
#6
Quote by AVA_Plus44_182
No, I'm not talking about recording two instruments at once, I'm talking about having one instrument lining in but having the computer recording the one signal onto two recording channels, therefore increasing gain on that channel.


I understand what you're saying. The problem i'm having is.. from the moment I boot my computer, without loading any audio programs - I can play my guitar and it will output to my speakers. This is what I want to stop. That pass-thru. I don't want what's going into my line-in to output my line-out UNTIL I tell FL to do so.

When I playback anything I record via line-in to FL it sounds fine. The real issue here is an accurate monitor.

But more importantly, since i'm getting better sound quality with the USB i'd really like to utiliize that. Maybe this is the approach I should be concentrating on. So, how do I get my audio to output via LINE-OUT when I am inputting via USB?
#7
Contact the makers of Fruity Loops...you paid for their software..now go get some support!