#1
So i just got a Carvin SX300 and i think it might be defective. First of all the amp buzzes more than i would think is normal (keep in mind that this is my first real guitar amp and im not sure on how they are supposed to act, for lack of a better word), it also like makes a cracking noise every few seconds. Im pretty sure something is wrong with it, but im not sure.

I would really like to know if this is normal, please help.
#2
Could be a bad cable for the crackling. What guitar are you using? Does it have single coils or humbuckers? Do you know if it's shielded?
Quote by Vincent Vega
Haikus are awesome
but sometimes they don't make sense
Refrigerator



Quote by KissingShadows
People always tell me I solo like Zakk Wylde. Thats how I know that I suck.
#3
Quote by thsrayas
Could be a bad cable for the crackling. What guitar are you using? Does it have single coils or humbuckers? Do you know if it's shielded?


I checked the cable on my old amp and its working properly. Im using an epiphone sg, humbuckers. Im not sure what shielded is.
#4
does the noise stop of you touch metal on the bridge?
Jenneh

Quote by TNfootballfan62
Jenny needs to sow her wild oats with random Gibsons and Taylors she picks up in bars before she settles down with a PRS.


Set up Questions? ...Q & A Thread

Recognised by the Official EG/GG&A/GB&C WTLT Lists 2011
#5
Quote by jj1565
does the noise stop of you touch metal on the bridge?


No, the buzzing is constant and the cracking happens at random times.
#6
the amp might be picking up buzzing from an ungrounded guitar that you couldnt hear before in your starter amp.

you can take out the jack see if both wires are attached correctly.



also, try the amp in a different outlet.

it might be picking up outlet noise.
Jenneh

Quote by TNfootballfan62
Jenny needs to sow her wild oats with random Gibsons and Taylors she picks up in bars before she settles down with a PRS.


Set up Questions? ...Q & A Thread

Recognised by the Official EG/GG&A/GB&C WTLT Lists 2011