#1
So my stack amp cuts off after like 10 mins HELP?!
I got my stack on thursday, its a Randall RH 150 G3 Plus, (yes i posted a question about amp cables yesterday)...

So im practicing with my band and it just cuts off, after numerous attempts of switching leads it still didnt work..

So i left it for 10 to cool down, (even though i wasnt cranking it!!)as most people do and i come back and its working fine, then after another 10 mins it cuts off again!

So i didnt it another few times too see if that was a one off. I tried it with my GT 10 in and with out and it still cuts off after 10 mins.

The lights are still on and every thing its just teh VOLUME!, i think its the cab but i dont have a clue!! The chanels still change etc. just no sounds is outputed. (YES I HAVE CHECKED ALL THE CABLES!) But still make suggestions (:

I would be delighted if some one can help.

THANK YOU,

Im going to contact the customer service of thw website i bought it off 1st thing tomrow morning! Dont worry

... once again THANK YOU!
The Pharaoh Of Thrash!

God Hates Us All ... .. R.I.P Brother Dimebag Darrell and Cliffy Burton

The Rig

-Dean Razorback 255 w/ EMG 81 & 85's
-Randall RH-150 G3 Plus Stack 150w
-Boss GT-10

MY SPACE!
#3
Probably a heatsink that is a little loose or something, so it cuts out after it overheats.
#4
bring it back to the store and buy a new (or better) amp.

if you dont want to do that:
have you change your guitar's pickups' batteries ( if you use EMGs) ??
PSN USERNAME: MetuulGuitarist7
STEAM:MetuulGuitarist7
Origin:MetuulGuitarist7
feel free to add me
#5
maybe you shouldnt buy a 300w amp?
i have a 5w tube and it super loud
anyways
try checking if your buddies pull the cable,or even a prank
check all the inputs..
Just call me Julius, J, etc.
Taking an Internet break for a while, will come on when I can.
#6
Quote by SlashYourFug
If you bought it from a store, you could probably take it back to them and get a new one.

this, if no then customer service
Warning: The above post may contain lethal levels of radiation, sharp objects and sexiness.
Proceed with extreme caution!
#7
Quote by bnull24
Probably a heatsink that is a little loose or something, so it cuts out after it overheats.


Thats probably the most plausable answer, ill ring the company as i bought it off the net and see what they can do and get a new amp sent out to me or repaired.

Thanks (:
The Pharaoh Of Thrash!

God Hates Us All ... .. R.I.P Brother Dimebag Darrell and Cliffy Burton

The Rig

-Dean Razorback 255 w/ EMG 81 & 85's
-Randall RH-150 G3 Plus Stack 150w
-Boss GT-10

MY SPACE!