#1
yes ive did searches for my issue and read the disk that came with it.
I cant get a setting to rid myself of the echo. just want a clean setting with no echo
#2
Push either the effects or stompbox button in, and turn down the 'mid', 'high' and 'post gain' settings to remove delay (the mid and high settings) and reverb (the post gain setting). Once you're done, press the effect/stompbox button again and you're all set.