#1
Hi guys,
So yeah, I got this peavey envoy 110 with a cort x11 with emg hz pickups for christmas,
And when I go on the lead(distortion) channel, the sound is horrible , its okay with power chords but when we do chords that involve about 4 notes, it gets unreconisable.
A friend lent me his boss ds 1 distortion pedal but it didn't work -_-
So I was wondering if its just peavey or my amp has a problem and I should go to the shop and have it changed
Thanks
#2
You've played other amps with distortion right? I mean that's kinda what distortion does, but it's hard to tell the extent of the problem without comparing it to something.
#3
That's fairly common using the built-in saturation on transtube amps. If you want to play full chords, roll back the saturation or switch to the clean channel.

Did you try the DS-1 through the clean or lead channel? Plugging a distortion box into an already distorted channel usually ends up sounding crummy.
#4
periphery/bulb!

gear:
Ibanez RG7321 w/ D-sonic in bridge

Peavey 5150 mk ii & b52 4x12 cab

line 6 podxt for recording

Quote by AsOneIStand
Head and Cab for $130? You don't need a head and cabinet, you need a psychological examination.
#6
you said that your problem was muddy distortion, not muddy cleans
periphery/bulb!

gear:
Ibanez RG7321 w/ D-sonic in bridge

Peavey 5150 mk ii & b52 4x12 cab

line 6 podxt for recording

Quote by AsOneIStand
Head and Cab for $130? You don't need a head and cabinet, you need a psychological examination.
#7
No, I meant that when I tried the ds1, I plugged it into the clean channel, but it didn't work :
And it's the distortion channel which is muddy
#8
Put it on the modern channel for distortion. Turn your gain down some. Mids not to high. Lows NOT MAXED or it will be muddy. Highs not maxed. Boost not maxed.