Good morning,

I have been recording songs over the past year using my m-audio USB fast track and reaper.

One annoying thing that I just learned to live with is the fact I cannot hear how what I'm playing sounds through my computer. I basically hear the guitar "unplugged", and only when I'm done recording can I then listen to how it actually sounds in reaper.

When I allowed "instant" playback of the input, there would be a 2-5 second delay between what I play and what comes out of the speaker. I researched a bit and was told to use ASIO4ALL to resolve this latency issue between the fast track and my computer.

Unfortunately when I go into reaper and select ASIO4ALL, I can then no longer select my soundblaster (for mic) or my m-audio device. Thus it was pointless as I couldn't even get the guitar to connect once I activated ASIO4ALL!

If anyone has done this before and could walk me through how to get reaper to record using ASIO4ALL so I can hear what I'm playing through my comp speakers as I play it - that would be fantastic.
My Gear
Epi Les Paul
Roland Microcube
Boss DS-1 pedal
Shure SM57
M-Audio Fasttrack
Ok , where you select your ASIO4ALL in reaper, there should be another click box for "configure ASIO"

Click on this and ensure that it has picked up all of your inputs and outputs and that you have set them all to enable.

I was using my x fi to record my guitar previously and when I added a second usb interface, discovered that the ASIO4ALL config didnt automatically enable it for use in reaper.

I had to go to the ASIO configure and enable it in there before it would allow me to select it as an input.

Once its running its great, I have my x fi recording my mic and my usb interface recording my guitar and I can monitor it all in realtime from my xfi with any vst effects I want , all of this with no percievable latency.

Im not at home for another week yet , but I have this same setup with me on my laptop as well so I know it does work.
ok, thats how i run things as well, so i know it works. and since they say a picture is worth a 1000 words, ill give you a picture. follow the red boxes (then read the explantion at the bottom)

first thing is where you should have asio4all selected. second thing is where you open the panel to actually mess with asio4all. third is the simple view of the pop-up, click the button i highlighted to go to the advanced screen. fourth we have the advanced screen, where you make sure everything you want to use is highlighted. i usually turn off things i dont want. fifth we have the section where you actually pick your ins and outs.

any questions, feel free to ask.
the M-Audio interface should have it's own ASIO drivers, so you shouldn't really need ASIO4All, did you try adjusting the buffer on your interface?
make Industrial and/or experimental electronic music? Join my group!