#1
My new V-33 makes a slight "pop" when I switch channels.. also seems to be a little bit noisy, though that is probably just poor shielding in my appt. thoughts on the channel switching thing?
Quote by Cathbard
Quote by Raijouta
Unless its electronic drums.

BURN THE WITCH!!!!!
#2
It does that with mine, too. I think it's the reverb tank

I don't notice because I don't switch channels
#3
flux ionizer has dust in it.....its the magnetic accelarator that alternates between the two circuits.
#4
^ sounds like you know what your talking about... i dont. so where should i blow real hard... haha
Quote by Cathbard
Quote by Raijouta
Unless its electronic drums.

BURN THE WITCH!!!!!
#6
i thought i could avoid such a joke.... so what can i do?
Quote by Cathbard
Quote by Raijouta
Unless its electronic drums.

BURN THE WITCH!!!!!
#7
in all seriousness i d say check if it happens more at higher volumes....if it does it could be something in the preamp section/tubes....if its not that its in the circuitry in which case you could probably get it fixed at a tech.
#8
no its really not loud at all, even when the amp is cranked. its not even really a problem to me, just wondering if it is a sign of something bigger.
Quote by Cathbard
Quote by Raijouta
Unless its electronic drums.

BURN THE WITCH!!!!!
#9
yeah then its just a circuit pop....does it happen more when yuou go from low gain to high gain or is it the same for either way?
#10
same for both i think may be a little worse form low to high
Quote by Cathbard
Quote by Raijouta
Unless its electronic drums.

BURN THE WITCH!!!!!
#11
yeha well its just a pop from a low gain stage to a high gain stage or vice versa but its cool....no biggie especially if you say it doenst get louder with volume