#1
I own a Mesa Boogie 30 watt tube amp, a (dual caliber)DC-3, and I bought it used from a guy mid-August and have had no problems with it. The guy was just selling the amp because he needed money and his wife was hinting to get rid of some amps because she wanted more room in the basement, he wasn't trying to rip me off in other words. So It was working yesterday, now it isn't, I plug it in and let it warm up like always and I noticed the channel switcher light(s) were not on so I re-inserted the foot switch and nothing happened, I changed the cables for my guitar 3 times and none of them worked, the same buzzing sound that gets louder with the volume, I also tried my other guitar and nothing changed. Is it the tubes? The speaker? Wiring? Please help!!!!!
PANDEMIC GROUP

Slash is trash

I has golfclaps!
Quote by RevaM1ssP1ss


Quote by boreamor
Your avatar is the first thing that has made me laugh in a long time. I applaud you


Quote by superslash1994
Lmao, your avatar earns you a golf clap.
.
#2
flick the standby switch.
---------------------------
Main gear
Prs Custom 22
Gibson LP Junior
Marshall DSL 50 Head
Marshall 1936 2x12
Trex OD, MXR Super Comp
Korg Pitch Black, MXR Carbon Copy.
PedalTrain 2 (soft case)
#3
^ that and check tubes..............
PSN USERNAME: MetuulGuitarist7
STEAM:MetuulGuitarist7
Origin:MetuulGuitarist7
feel free to add me
#4
I did that too. That is how I get the buzzing, without it just silence.

EDIT: How will I know what is wrong with the tubes?
PANDEMIC GROUP

Slash is trash

I has golfclaps!
Quote by RevaM1ssP1ss


Quote by boreamor
Your avatar is the first thing that has made me laugh in a long time. I applaud you


Quote by superslash1994
Lmao, your avatar earns you a golf clap.
.
#5
Quote by swordsrkewl
I did that too. That is how I get the buzzing, without it just silence.

EDIT: How will I know what is wrong with the tubes?


Make sure they aren't loose.
Quote by Vincent Vega
Haikus are awesome
but sometimes they don't make sense
Refrigerator



Quote by KissingShadows
People always tell me I solo like Zakk Wylde. Thats how I know that I suck.
#6
The tubes themselves are not loose, seemed pretty fastened in there. But is there something INSIDE the tubes I need to be looking for?
PANDEMIC GROUP

Slash is trash

I has golfclaps!
Quote by RevaM1ssP1ss


Quote by boreamor
Your avatar is the first thing that has made me laugh in a long time. I applaud you


Quote by superslash1994
Lmao, your avatar earns you a golf clap.
.
#7
If the footswitch aint lighting up you may have a fuse problem/wiring problem within the amp. The tubes may be fried too if you get the crackling too much.

But since the footswitch ain't lighting I am betting little/no power is running through the amp.
#8
How do I get MOAR POWER?
PANDEMIC GROUP

Slash is trash

I has golfclaps!
Quote by RevaM1ssP1ss


Quote by boreamor
Your avatar is the first thing that has made me laugh in a long time. I applaud you


Quote by superslash1994
Lmao, your avatar earns you a golf clap.
.