#1
My EHX Small clone arrived today, and it's not working properly

I plugged it in correctly, checked the battery was right (even switched it out and replaced it) and the pedal turns on, but it doesn't seem to do anything. The red light is on, but I'm not hearing the chorus effect that I hear on the demo videos on the ehx.com website.

Please help me out!
#2
I entered this thread with hopes of cloned midget related questions. *sigh*
GEAR
________

Jackson RR3 w/ Dimebucker
Epiphone G400 Extreme
Marshall Mg30 Dfx (It does the job),
Kelry Sinister Strings, 10 - 52's
Dunlop Jazz III's or Dunlop purple 2.00 tortex(sharpened).
#3
put the depth switch up and turn the knob all the way to the right...does that change anything?

Whodicted



Quote by stevo_epi_SG_wo
france is laaaaame


Recognized by the Official EG/GG&A Who To Listen To List 2009
#4
No. =(

EDIT: Well you can hear a slight change in sound, but its very very slight, and it's most certainly not chorus.
#5
Chrysler Voyager
edit: sorry other thread
01110111001101101
10101101000
0110010
0101
01
0
******A Console Cowboy****** 1
01
0101
0110010
10101101000
01110111001101101
#6
Quote by michal23
No. =(

EDIT: Well you can hear a slight change in sound, but its very very slight, and it's most certainly not chorus.

send it back then...easiest way

Whodicted



Quote by stevo_epi_SG_wo
france is laaaaame


Recognized by the Official EG/GG&A Who To Listen To List 2009
#7
It's already been a real hassle with the company, I'd really like to avoid dealing with them again. So if there's a simple way of fixing this, then I'd rather do that. Of course, if no one has a solution, then I have no choice.
#8
Open up the inside, check for loose wires or bad soldering or anything out of the ordinary. I would especially check the switch, make sure that everything there is wired properly.

And then if it still doesn't work, send it back. EHX is not lauded for their quality control.
Fighting the good fight since 'ought-diggity.

My Gear

"When you think of it, a really good effect should not mean that your search is over; it should mean that your journey is just getting started."
#9
Check all the usuals first...make sure all you cables are plugged in tight, try a different cable, try a different guitar, etc. Then take it apart and see if you can see any loose connections. The Small Clone isn't great to work on so I'd try to send it back...usually these pedals are pretty solid.
#10
It looks okay... but I really know next to nothing about electronics and circuit boards and **** like that, so I really won't be able to tell you whether it's okay or no. :/