Alright so I wasn't having this problem yesterday when I recorded a track off of my line6 toneport.
Basically what I do is export my midi from guitar pro and import it into cubase and import my ezdrummer plugin. I then set the drums to use the ezdrummer, it was working fine yesterday. Now when I do it, the drums start a bit early, so its all messed up with other instruments... like the midi tracks will start a fraction of a second after the vsti track will. Its not just ezdrummer even cubase's plugins do that... Reinstalling didn't help... please tell me why this is happening.

Probably latency. VSTis use MIDI tracks, so all of your tracks are MIDI.


THE SINE WAVE SURFER σƒ τλε τρπ βπστλεπλσσδ


[quote="'[BurnTheDusk"]']Boss pedals may be built like tanks but I would rather buy a cardboard box that is on my side than pay for a tank that is working against me.
but see it used to work fine before, I didn't change anything, I mean I did hook up my toneport yesterday for the first time and changed that to my ASIO but I changed it back to my realtek audio card. How do I change this latency issue? Before vsti'd midi tracks and normal midi tracks synced pretty damn nicely!
Check your Device Setup settings, including Drivers and Latency. Change everything to default (write down your current config first), restart Cubase, if that doesn't help then revert it to your preferred configuration and it should almost definitely work then :|
man these forums move fast,

Anyways, I have tried tampering with the device setup settings (I did change them yesterday to use toneport as the asio) but nothing seems to work... I mean I have selected different options but the vsti tracks still start faster...

Anyone with a solution?
you should ask up in the riffs and recordings forums. its not just for already recording stuff, the gear chat is in the main forum if you scroll down past the subforums.

as far as your problem goes.. i have NO freaking clue
Grammar and spelling omitted as an exercise for the reader.