#1
So i retubed my VK 212 since all the power tubes were blown, everything is working fine except for when its on the lead channel the volume doesnt get past talking volume. This problem existed before i retubed it, but the amp went completely out, so therefore i changed ALL the tubes. They are all in correctly and tightly. So i was wondering what my problem could be?
#4
the problem is that you have a VK, which are notorious for these sorts of problems, take it and get it serviced.
make Industrial and/or experimental electronic music? Join my group!

Last.fm
#5
i dont get a part of it. You mean that your lead channel has a loss of volume? Does it lose gain too? If you move the volume knob, does it make a difference?
GRUPO EN ESPAÑOL

SI BUSCAS BANDA EN LATINOAMERICA O ESPAÑA, ENTRA AQUI
#7
Quote by Kid_Thorazine
the problem is that you have a VK, which are notorious for these sorts of problems, take it and get it serviced.

Since when? That's the first I've heard.

The amp doesn't need biasing #1. Did you buy a 'matched' and balanced quad of tubes and from whom? Preamp tubes are cheap. I'd buy at least one and swap it around to rule that out. Is this amp new or used? You have absolutely ruled out everything else - guitar, pups, cables etc.

<flameshield> as I'm not saying you are an idiot.
#8
Yeah, i replaced all 7 tubes, I got the tubes all in a set from eurotubes, matched. I know it is the amp because i have used the same guitar and cable, etc. on a different that works fine.
#11
Quote by 311ZOSOVHJH
Since when? That's the first I've heard.



Then you don't pay much attention, hell one of the stores around here stopped stocking them because they got so many returns due to crap like this.
make Industrial and/or experimental electronic music? Join my group!

Last.fm
#12
You got some bad pre amp tubes if it's only the lead channel. Doesn't matter if just got new ones. New ones come bad a LOT. I bet that is the problem. Test out the preamp tubes. Switch some over to the clean channel and see what happens.
#13
+1

I'm starting to think the same thing. Is there any difference with the preamp tube change? What exact tubes did you get? I have heard stories about bad tubes coming out of eurotubes.com


Quote by Kid_Thorazine
Then you don't pay much attention, hell one of the stores around here stopped stocking them because they got so many returns due to crap like this.

Did you just say I'm not paying attention? I see just about every Valveking question that comes in here and I'm a regular poster in The Valveking Thread. Regardless, your posts in this thread are offering Zero help. Which store quit stocking them BTW?
#14
Quote by 311ZOSOVHJH
+1


Did you just say I'm not paying attention? I see just about every Valveking question that comes in here and I'm a regular poster in The Valveking Thread. Regardless, your posts in this thread are offering Zero help. Which store quit stocking them BTW?


Local place around here.

and I did offer help I told him to take the thing to a tech, which is the ideal recommendation for situations like this.
make Industrial and/or experimental electronic music? Join my group!

Last.fm
#15
the valveking just sucks anyway. I don't see how you guys even deal with those tones.
#16
Quote by Kid_Thorazine
Local place around here.

I realize it is a local place. What is the name of the place?

VK doesn't come with the greatest speakers and tubes granted, but can get some decent tones with tweaking and swapping. Some of the most recent clips by VKs are pretty damned good.


TS - I would contact eurotubes and ask them what gives.