#1
I used a weird kind of adapter for my mxr phase 90 pedal and now whenever i plug a battery and chords into it it doesnt work and the battery starts to heat up. Does any one kno how to solve this problem.
#2
If you plugged the wrong adapter in you most likely fried the pedal.
I don't give a shit if you listen to me or not
#4
Quote by EVH51501234
is it possible to reverse that and/or how do u fix it?


As far as I know, there is no way to fix it without buying new parts.
#5
You probably need to replace every cap in the pedal for starters. The IC is probably toast along with any transistors.
I don't give a shit if you listen to me or not
#8
Mouser.com no guarantees it will sound the same though. It's probably be easier just to buy a new one considering all the desoldering and soldering you'd need to do.
I don't give a shit if you listen to me or not
#9
You might end up replacing 90% of the parts to find the bad ones. Might as well build a new board for it. And use the correct adapter next time.
#10
Just buy a new one dude. It's not worth it to rebuild. Soldering on PCB's is delicate work, and very easy to bollocks-up (I've done it). A new one is $60 anyway isn't it, or did they go up on them?
#11
Quote by EVH51501234
where could i buy new parts and how much would they cost?

Your pedal is dead. There is no point wasting tons of time, energy and money trying to fix it. Getting a new one would be a lot cheaper and easier. Well done!

╠═══════╬═══════╣

THE SINE WAVE SURFER σƒ τλε τρπ βπστλεπλσσδ

╠═══════╬═══════╣


[quote="'[BurnTheDusk"]']Boss pedals may be built like tanks but I would rather buy a cardboard box that is on my side than pay for a tank that is working against me.