#1
I recently retubed my Mark IV and all of the tubes seem to be working okay (ish). My master volume goes up to about 5 whilst crackling all the way and then procedes to lower in volume on the way to 10. My rhythm 2 channel seems to have lost some gain and ooomf as well; that is why I said my tubes seem to be okay because therefore it would seem they are not.

Judging by ^ power tube issues are ruled out, no? I'm led to believe by Bob at Eurotubes that my crackling retarded master volume is due to a faulty pot. Would a faulty/dirty pot be able to cut the volume in half like that? I am not familiar with going inside the amp, but if one could tell me how to safely drain all the voltage and what to look for/how to clean it I have an uncle who is an electrical engineer who would know what those parts are and could help me not shock myself.

Finally, about that rhythm 2. It would seem like I should just work those preamp tubes in and out once or twice, no?


it is f'n late I'm possibly the last person up in America. :stickpoke:
#2
I would have an amp tech work on it. Definitely not worth potentially killing yourself over saving a few bucks.
#4
I am ignorant in this area, but from my miscellaneous reading, I think your change in Rhythm 2 could be due to a tube change. If it was, however, I'd imagine that all channels your amp would experience a change in the amount of gain and "oomphf" you could get.

I strongly recommend you not attempt to do anything yourself if you don't understand the workings of your amp, and to seek help from your uncle or an amp tech.
#5
Quote by slimp
I would have an amp tech work on it. Definitely not worth potentially killing yourself over saving a few bucks.


concur 100%. quite a few different things could be wrong with it anyways.
Quote by kcdakrt
DLrocket89 makes my ug experience better!


Member of the official GB&C "Who to Listen to" list

Kit Amp Building Tutorial