#1
I'm planning on getting the Line 6 Tonport GX 1 but on the website it says I need Windows XP Service Pack 2. I currently have Service Pack 3. Will I still be able to use it?

The answer is probably obvious but I just want to be 100% sure before I buy this thing.
#3
SP3 is nothing like SP2 in terms of compatibility issues and shouldn't cause any problems, SP3 is essentially a whole bunch of security upgrades and minor system tweaks, whereas SP2 was a fairly major overhaul of the whole OS. So yeah you'll be fine.
make Industrial and/or experimental electronic music? Join my group!

Last.fm