#1
yesterday my blues deluxe was doing something weird...now usually around level 4 it will start to break up, but now it seems it breaks up extrememly around 2 and 2 was pretty much clean, it always got a little dirty when i played hard just running right into the amp, but it barely took any effort to get some nasty crunch out of it at low volumes and not really digging into the strings on the guitar.

checked the tubes and although they were glowing bluer than normal i couldnt see anything that was wrong with them.

oh and this crunchy sound wasnt pretty! it sounded like a crunch channel at very low volume, pretty cold sounding.
Last edited by WaltTheWerewolf at Mar 27, 2009,
#6
Sounds like a tube issue.
Probably the power tubes, but it wouldn't hurt to swap out the preamp tubes too.
Call me Wes.
Gear:
Fender American Deluxe HSS Strat
Chicago Blues Box Roadhouse
Bad Cat Cougar 5
1957 Gibson GA-5
Ceriatone 18w TMB Combo
Hughes & Kettner Tube Factor
Various Ibanez TS9s
Weber MASS Attenuator
#8
I wouldn't go for Ruby. They're just rebranded.
They wouldn't be much of an upgrade from stock Groove tubes or whatever crap Fender is putting in their amps nowadays. Of course, unless they decided to rebrand some JJs or tungsols

But i'd just go for the sure thing and get some JJ power tubes, and maybe JJ or Tungsol preamp tubes. I would recommend you try out an assortment of preamp tubes. I've never liked the tone of amps with just one brand of preamp tube straight across the board.
Call me Wes.
Gear:
Fender American Deluxe HSS Strat
Chicago Blues Box Roadhouse
Bad Cat Cougar 5
1957 Gibson GA-5
Ceriatone 18w TMB Combo
Hughes & Kettner Tube Factor
Various Ibanez TS9s
Weber MASS Attenuator