#1
Alright, i have an Acoustic B200 bass amp, and when i play with my band (2 guitars, drums, and me), the speaker cant handle the volume and distorts, or just plays some specific notes really quiet, the clip light isnt lighting and it just doesnt work right. It is really annoying, and i cant figure out how to stop it. i dont know if its somthing simple or if i need to get a new speaker. Any help is appreciated, thanks.

PS: i do have a warranty on the amp, if you think i'd be better off just taking it in. but i'm not sure if its just this one or if they all do it.

Also, its not like i have it all the way up, i have the gain at about 1:00 and the volume at 10:30, with my bass' volume at about 1/2.
Last edited by GrifsGotDibs73 at Jul 1, 2009,
#4
Sounds like the amp itself is just not working right. What specifically is wrong when you're playing? Because distortion shouldn't really happen at 1/2 volume.
Quote by rebelmidget
I do believe you just used Blink 182 and hard rock in the same sentence. It would seem you're rather confused.
I have a quote in my signature! And it makes fun of blink-182! I'm cool now!

[Obligatory link to my band's MySpace]
#8
its solid state, and when i play the notes just sound like they are being crushed or something. its hard to describe. Like the amp cant get the note to come out, it sounds like it is blown or somthing. Should i just bring it in and see if they'll give me a new one?
#10
Quote by GrifsGotDibs73
its solid state, and when i play the notes just sound like they are being crushed or something. its hard to describe. Like the amp cant get the note to come out, it sounds like it is blown or somthing. Should i just bring it in and see if they'll give me a new one?

Yeah, the speaker is definitely blown out. If it's under warranty, take it in and get the speaker replaced, or just trade it in for a new one.