#1
It's not a problem with my amp. I saw a JCM head at a live show that was turned on, but the red power switch didn't light up. Is this normal for any JCM models, or a fault?
#3
It's totally normal, the Jonas Brother's amps never light up, their mics don't either.
Lets jump in a pool


_____________________________________________
Last edited by I am wet : Today at 03:26 XM.
#4
Quote by I am wet
It's totally normal, the Jonas Brother's amps never light up, their mics don't either.


Actually their mics do, that is the reason we suffer.

And it's possible it was just there for show and not actually being used. Or being used as a backup.
#6
Quote by I am wet
It's totally normal, the Jonas Brother's amps never light up, their mics don't either.



icwutudidthar
Official Aspie member

ANOUNCEMENT: Weird misspellings or words that make no sense? there was a good chance this was sent from my Droid 2 phone.
Quote by SinisterStrieth
.. You are the man.

RIP Dime RIP Michael Jackson
#8
Quote by BrickIsRed
I guess it was just a broken switch. There was no other amps around.

The light was probably burned out, just like tubes, use it alot and things are going to die.
Lets jump in a pool


_____________________________________________
Last edited by I am wet : Today at 03:26 XM.
#9
LEDs have a ridiculously long lifespan. The one in my '81 800 still works after nearly 30 years.

The connection probably came loose and nobody cared, since it's not part of the signal path.
Everyone is entitled to an opinion.

Feel free to express yours so I can make an informed judgement about how stupid you are.