#1
I have a peavy valveking 112
and every time i strike a note on my guitar it plays the note but with a crackling fizzy sound behind it,
it also random does this when im not playing

now i looke dround the back and the 2 6L6 are glowing as normal
so i thought it might be due to one of the preamp tubes
but i dont really know

any ideas?
GEAR
94 Fender Stratocaster Plus
02 Gibson Les Paul Special (modded)
Orange AD-30 Combo


The SG Thread pwns your thread.
#3
Check the ground wire on the inside of the amp to make sure its clamped securely to the chassis.

You want to be grounded to reduce noise and any chance of electrocution.
GTFO my sig
#5
Quote by kyle62
I assume you're plugged straight into the amp? try different leads/guitars first, that could also be the problem. Does it only happen at certain volumes?


Yes plugged straight in
the lead is fine its a brand new planet waves one
i also tried it with other leads same problem same with diff guitars
and it happens at every volume

sometimes all the time sometimes only a little mostly on the distortion channel or when i put a distorted pedal through
but it also happens on clean sometimes
GEAR
94 Fender Stratocaster Plus
02 Gibson Les Paul Special (modded)
Orange AD-30 Combo


The SG Thread pwns your thread.
#6
Quote by kyle62
I assume you're plugged straight into the amp? try different leads/guitars first, that could also be the problem. Does it only happen at certain volumes?

were would i locate this
and i thought if it was a grounding problem it would be a constant buzz
GEAR
94 Fender Stratocaster Plus
02 Gibson Les Paul Special (modded)
Orange AD-30 Combo


The SG Thread pwns your thread.
#7
take it to a tech, it sounds like a cap problem to me, I had similar problems with bad coupling caps, or bad filter caps in the power supply can sometimes cause this kind of problem.

I also had similar problems when I removed the main board from my amp and didn't bolt it down tight and had a loose bolt under the chassis rattling causing some intermittent noise.
#8
Quote by al112987
take it to a tech, it sounds like a cap problem to me, I had similar problems with bad coupling caps, or bad filter caps in the power supply can sometimes cause this kind of problem.

I also had similar problems when I removed the main board from my amp and didn't bolt it down tight and had a loose bolt under the chassis rattling causing some intermittent noise.


oh ffs
GEAR
94 Fender Stratocaster Plus
02 Gibson Les Paul Special (modded)
Orange AD-30 Combo


The SG Thread pwns your thread.