#1
I couldn't find a forum for guitar maintenance, so I'll put this here.
When I plug my guitar in, all I get is a slightly distorted, extremely quiet sound out of it. It's sounds as if I put it on a light distortion and put the volume on 2. Is this an input jack problem, a pick up problem or what? I tried multiple amps, I am sure it's my guitar. And if it's any help it's a Schecter C1-FR.
#2
Sounds like pickup maybe, but if you're going to be checking the pups you might as well check the input jack as well.
#3
What pickups do you have on it? Are they active? If so then have you tried replacing the battery?
#4
Unscrew the input jack check its not bend.Check all the wires are connected.Check amp connected to speaker.
My Gig Rig...

Fender Straocaster or Gibson Les Paul Slash Special -->Lovepedal Amp 50 --> Boss DD-3 --> Crybaby(soon to be Wh10 reissue) --> Big Muff PI --> Boss DS-2 --> Marshall JCM 900
Last edited by ChiliFan01 at Jul 29, 2009,
#6
Change the battery. It happens to Active Pickups; without a 9V (or several, depending on mods), you won't get a sound out of them.
#7
Thanks guys, I'm actually convinced it might be the pickups because they're active. So they just run on regular 9V batteries? And where do I put the batteries? Do I have to take the pickups out?
#9
Quote by BenMags
Thanks guys, I'm actually convinced it might be the pickups because they're active. So they just run on regular 9V batteries? And where do I put the batteries? Do I have to take the pickups out?


On the back of your guitar there should be a box for the batteries itself if there isn't then open up your control cavity and the battery would be placed in there.
#10
Thanks guys. And yeah, there's a plate on the back. I was just curious if I had to take the string off. Floyd Roses are a pain in the ass.