#1
Ok, following your guys advice from the earlier "Should I reinstall Starcraft" thread.

(Protoss FTFW by the way.)

anyway, when I tried to install it, this little thing came up.



So basically what I am asking is. What the hell does this thing mean and is there a way to get around it. If so then how.

If I have to buy a new copy, will this same thing even happen?

And yeah, among other things, wtf is going on.

I have a macbook pro if it matters.
VERY METAL!
\m/
RIP Ronnie James Dio

Quote by metaldud536
RazorTheAwesome, if I was a Ditto, I'd transform into YOU

Quote by Kensai
Basically god wanted to punish people for getting educated/eating apples.

Quote by Jackal58
We all desire a little pussy.
#2
I wish I had a mac..


but I have no Idea what you're on about otherwise..
"You're a twat!"- That dude in morrisons

"You Ugly git!" - That girl in the restaurant

"You Were a Mistake!" - Mum

just a few of my fans..



#4
Quote by batman187
You can't install it because the classic environment is no longer supported.


I know but what the **** does that even mean?
VERY METAL!
\m/
RIP Ronnie James Dio

Quote by metaldud536
RazorTheAwesome, if I was a Ditto, I'd transform into YOU

Quote by Kensai
Basically god wanted to punish people for getting educated/eating apples.

Quote by Jackal58
We all desire a little pussy.
#5
I'm thinking your OSX version is too recent, by the sounds of it.
Posted from Ubuntu.

Squier Precision Bass Special in Antique Burst (LH)
Rotosound Swing 66s, 45-105

On slapping on a bass:
Quote by supersac
pretend its a woman
i have no helpful advice

#7
Quote by druggietoad2k5
I'm thinking your OSX version is too recent, by the sounds of it.

Yeah, your OS is to new. Maybe try getting it to dual boot with 10.2 or something.
Gear:
Squier Strat
Cordoba 20TM-CE Acoustic Electric Tenor Uke
Bugera V22
#10
Quote by MLilienthal
Blizzard games run great on macs but I would think that SC is just too old


but its still a ****ing awesome game.

And is there a way to install it without downgrading my software?
VERY METAL!
\m/
RIP Ronnie James Dio

Quote by metaldud536
RazorTheAwesome, if I was a Ditto, I'd transform into YOU

Quote by Kensai
Basically god wanted to punish people for getting educated/eating apples.

Quote by Jackal58
We all desire a little pussy.
#11
It's non compatable. Macs aren't very reverseable. :P
Quote by guitar-godfrey
when i grow up i wanna have blackandsilver's babies!

Quote by angusfan16

Quote by Scowmoo
..
HOLY HELL.

nice discovery, sir.


--------------------------------------------------------------------------------
Last edited by coryklok : Today at 01:10 PM.
#13
Starcraft was designed around OS 9, which is considered the last 'classic' environment of the mac OS.

Blizzard has updated their installation software to support OSX, and its available for download on their website.
Quote by jackbauer
playing by yourself is like masturbating, sure it feels great, but it's nothing compared to the real deal.


Quote by guylee
Oh Shit! I Have A Weird Growth On My Body!

To The Pit!



JOIN MY GROUP plox

http://groups.ultimate-guitar.com/tonelife/
#15
Isn't it obvious that it's global warming! Hello!
If You See Me Posting In The Pit HIT ME.
Quote by KingJak236
My hamster used to bite me when I picked it up, then it got too old and fat to bite and died in a pool of it's own vomit.

Quote by Kensai
That's the rockstar way to go. I salute him.
#16
Quote by RazorTheAwesome
but its still a ****ing awesome game.

And is there a way to install it without downgrading my software?

Yeah it's an amazing game
SC2 should be out within a year
I'm droolin over Diablo 3 at the moment but that will be a long long time
#17
Unfortunately not, judging by the error, its telling you that the original Starcraft classic mode aint supported by Mac OS X.
#19
Quote by entity0009


K thanks, I'm downloading it now, hope this works.

And yeah, I'll wait for Starcraft 2. Not sure if I'll get it though.

edit:

No this doesn't work because it already assumes that I installed the game.

Let me keep working with it, I might get it to work
VERY METAL!
\m/
RIP Ronnie James Dio

Quote by metaldud536
RazorTheAwesome, if I was a Ditto, I'd transform into YOU

Quote by Kensai
Basically god wanted to punish people for getting educated/eating apples.

Quote by Jackal58
We all desire a little pussy.
Last edited by RazorTheAwesome at Aug 1, 2009,
#22
Quote by SoWrongItsMatt
It's because you have a mac.


I don't need this from you
VERY METAL!
\m/
RIP Ronnie James Dio

Quote by metaldud536
RazorTheAwesome, if I was a Ditto, I'd transform into YOU

Quote by Kensai
Basically god wanted to punish people for getting educated/eating apples.

Quote by Jackal58
We all desire a little pussy.
#23
Quote by BlitzkriegAir
just get a PC like normal humans


Then what am i, with my dual boot OSX/Vista MacBook?

Posted from Ubuntu.

Squier Precision Bass Special in Antique Burst (LH)
Rotosound Swing 66s, 45-105

On slapping on a bass:
Quote by supersac
pretend its a woman
i have no helpful advice

#24
the classic environment is the emulator software that used to be part of OS X for running older Mac OSes, like OS 9. It was never supported on the newer Intel processor systems (like the MacBook and the MacBook Pro), and is no longer part of OS X (as of Leopard). Try the OSX patch that was mentioned earlier, you are not going to be able to run OS 9 software on an intel processor, not without some serious emulation.
You're using UG classic, congratulations.
You should be using UG classic.




E-Married to Guitar0Player

http://the llama forum because its gone forever which sucks and I hate it.
#25
You should have stuck with OSX Tiger.

>_>

<_<

|_|0|_|
|_|_|0|
|0|0|0|
▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄▀▄