#1
I was just playing on my peavey valveking 212 and the sound started going quieter. Then there was a pop (like when switching the amp off) and the power had gone. I switched everything off. Then decided to smell the back. Instead of the usual hot tube smell I could smell a dirtier thicker smell. A burning smell maybe?

Can anybody tell me what damage I am looking at here and how much I will be paying to get it fixed. Cheers.
#2
Can you still see the pilot light if you turn it on? If not, then you blew the fuse which is my first guess.

╠═══════╬═══════╣

THE SINE WAVE SURFER σƒ τλε τρπ βπστλεπλσσδ

╠═══════╬═══════╣


[quote="'[BurnTheDusk"]']Boss pedals may be built like tanks but I would rather buy a cardboard box that is on my side than pay for a tank that is working against me.
#3
Quote by paaaaaaaaaa
I was just playing on my peavey valveking 212 and the sound started going quieter. Then there was a pop (like when switching the amp off) and the power had gone. I switched everything off. Then decided to smell the back. Instead of the usual hot tube smell I could smell a dirtier thicker smell. A burning smell maybe?

Can anybody tell me what damage I am looking at here and how much I will be paying to get it fixed. Cheers.


Probably you power Transformer Broke down..
#4
something blew for sure. Oh and BTW, you are not suppose to hear a pop sound when turning it off. Let the tubes cooldown, there are still electrons in the tubes when you stop playing. Wait a bit before turning it off and let it in standby
To buy:

Line 6 MM4
Voodoo Lab power
Mesa Boogie Single rectifier
Done
Boss TU-3 Done
Shure SM58 Done



OUCH MY WALLET
#5
Yeah no light when I turn it back on.

@AmericanParadox - yeah I'm aware I need to let the tubes cool down. I obviously don't let them cool for long enough then.
#6
Are you in southern california by chance? i know an amazing amp tech
#8
Yep, you definetly blew the fuse in the amp if you get no lights after powering it up. It should be a cheap and easy fix at around a dollar for the fuse.

╠═══════╬═══════╣

THE SINE WAVE SURFER σƒ τλε τρπ βπστλεπλσσδ

╠═══════╬═══════╣


[quote="'[BurnTheDusk"]']Boss pedals may be built like tanks but I would rather buy a cardboard box that is on my side than pay for a tank that is working against me.
#9
Quote by Dr.Pain-MD
Yep, you definetly blew the fuse in the amp if you get no lights after powering it up. It should be a cheap and easy fix at around a dollar for the fuse.



Make sure you get the right fuse if you get a new one. All sorts of bad can happen if you dont