#1
I have a Peavey Classic 30 that I got maybe 2 years ago, and for a while it's been occasionally making really loud cracking or popping noises, and sometimes with a loud buzzing, droning, or humming sound on top of it all. I've tried a different guitar, different cables, and with/without pedals in front of it. If I play on a lower volume it doesn't happen as much, and it typically only happens after a few minutes into my playing.

What's going on here?
Gear:
.Fender Classic Series '70s Stratocaster
.Peavey Classic 30
.Xotic BB Preamp
.MXR Carbon Copy Analog Delay
.Vox V847A Wah
.Boss RC-2 Loop Station
.Washburn WI-24 (first guitar )
#2
Your compassador might be leaking. Gonna have to buy a new amp. I had the same problem but mine squealed at a 20 high octave range even when there is no guitar pluged in.
#4
my peavey valve king does the same thing for the first min or so at bedroom level i havent tried it louder
even if theres nothing plugged in and when its happenin it does not matter if u switch channels or fiddle with the volume it doesnt change in volume
GEAR
94 Fender Stratocaster Plus
02 Gibson Les Paul Special (modded)
Orange AD-30 Combo


The SG Thread pwns your thread.
#5
but then the amp works ok usually after that at low volume
GEAR
94 Fender Stratocaster Plus
02 Gibson Les Paul Special (modded)
Orange AD-30 Combo


The SG Thread pwns your thread.
#6
Quote by steve!
my peavey valve king does the same thing for the first min or so at bedroom level i havent tried it louder
even if theres nothing plugged in and when its happenin it does not matter if u switch channels or fiddle with the volume it doesnt change in volume



dude you gotta crank the vk and let it breathe
#7
Quote by ibanezgod1973
dude you gotta crank the vk and let it breathe


not when its crackling like this
GEAR
94 Fender Stratocaster Plus
02 Gibson Les Paul Special (modded)
Orange AD-30 Combo


The SG Thread pwns your thread.