#1
I just bought a Randall RG50TC a few days ago and now one of the power tubes isn't lighting up.I'm new to tube amps.Is this normal? Should I replace my tubes now? By the way it was a floor model so the tubes could of been used a lot for a while.

Oh and any recommendations on what tubes to get for metal? Metallica,Megadeth,Slayer kinda of sound but I also do a good bit of finger picking so something kind of versatile
Who Said Anything About A Signature ? ಠ_ಠ
#2
Pull the other tube, turn the amp on, see if the amp works. If it doesn't, you need new tubes. If it does, you're fine.

Whether or not a tube lights up is not a good indicator of whether or not it's working properly.

Furthermore, tubes fine tune your sound but if you're not getting the sounds you're describing out of your amp now, new tubes are not going to change that.
#4
Quote by Roc8995
Pull the other tube, turn the amp on, see if the amp works. If it doesn't, you need new tubes. If it does, you're fine.

Whether or not a tube lights up is not a good indicator of whether or not it's working properly.

Furthermore, tubes fine tune your sound but if you're not getting the sounds you're describing out of your amp now, new tubes are not going to change that.



I didn't get any sound so maybe I should chance my tubes.The one that was lighting up was a little bit black.I am getting a good sound i like now I was just wondering since i'm going to be changing them.
Who Said Anything About A Signature ? ಠ_ಠ
#5
If you pulled one tube and the amp stopped working, the other one is definitely dead and you're stressing your transformer with the impedance mismatch.
You should change the tubes and have the tech check to see if anything caused the first one to die while he's biasing the new set of tubes.