#1
(In)complete Idiot's Guide to VSTs and VSTis in Linux

I'm making this guide because it took me 3 days to figure out something that's really simple. Bear in mind that it may have mistakes since I'm a complete newbie regarding both VSTs and Linux.
I'm going to try to make this really simple so anyone can understand it.

I've only used really popular Linux distributions: Ubuntu 8.04 (Hardy Heron), Ubuntu 9.04 (Jaunty Jackalope) and recently, UbuntuStudio 8.04.

I really recommend UbuntuStudio 8.04 since it's specifically designed for multimedia production. However, many people (like me) don't have DVD burners so they can't really burn the iso image. An iso image is a file that you should burn in a CD or DVD. That's all you really need to know. You can do this with a lot of programs. I used Nero, I think.
So what did I do? Well, you install Ubuntu 8.04 (Hardy Heron). Once it's installed and running, open a terminal (Applications -> Accessories -> Terminal) and type:

sudo aptitude update && sudo aptitude install ubuntustudio-desktop ubuntustudio-audio ubuntustudio-audio-plugins ubuntustudio-graphics ubuntustudio-video linux-rt

There, now you've got UbuntuStudio 8.04.

Now, to be able to use VSTs and VSTis, you'll need a VST host. There are some tutorials dealing with FST host and something called savihost but I've read that DSSI VST host is way better. This is just a little research though, don't take it for granted. The problem is, you have to compile DSSI VST host, it doesn't come in a double-click-accept-it's-installed-now package.
Before installing the vst host, you need some packages installed. You should also install Wine (Applications -> Add/Remove...). (If it's not in the Repositories, go here: http://www.winehq.org/download )

After Wine's installed, open a terminal and type: (these are other packages needed to run dssi vst host)

sudo aptitude install wine-dev liblo0-dev dssi-dev libasound2-dev libc6-dev wine-dev gcc-multilib g++-multilib
wget http://downloads.sourceforge.net/dssi/dssi-vst-0.8.tar.gz
tar -xzf dssi-vst-0.8.tar.gz
cd dssi-vst-0.8/
make
make install


I must thank CheShA from the Ubuntu forums for this last piece of information. You can check the thread here: http://www.uluga.ubuntuforums.org/showthread.php?p=7804266


I don't know if these next steps are correct but they worked for me. Whenever I tried to use DSSI VST host, I'd get a lot of errors. What I did was:

1.- I renamed the "dssi-vst-0.8" folder to ".dssi" (without quotes, obviously) and moved it to: /home/username/.dssi
2.- I made a folder with my .dll files (these are the VST files) in home/username/vst (I think it has to be named exactly like this)
3.- If there are any .dll files with spaces in the name, delete those spaces from the name. Example: Addictive Drums.dll -> Rename to AddictiveDrums.dll


Now, let's get this thing in action. For this example, I'll be using the Addictive Drums VSTi (I installed this in Wine without problem).

1.- Open JACK Control (in UbuntuStudio 8.04: Applications -> Sound & Video -> Audio Production -> JACK Sound Control)
2.- Open a terminal and type:

vsthost AddictiveDrums.dll

3.- Open Rosegarden (procedure similar to JACK Control)
4.- In Rosegarden, change the device to whatever makes Addictive Drums sound. In my case it was changing from "General MIDI" to "MIDI software device 5"

Now you can import a midi file and play it in Rosegarden but you won't hear your ****ty soundcard synth but Addictive Drums!

English is not my mother tounge so if there's some confusing stuff, I'll try to make it clearer. Also, please point out any mistakes I made.

I'd like to attach pics of how Rosegarden and JACK Control look but I'm to lazy to do it. If someone's got an ImageShack (or similar) account, I'll PM her the pics and we can post them there,

Additional notes:

Whenever I do the "vsthost AddictiveDrums.dll" step, I get the error:

Plugin server timed out on startup:
No such device or address vsthost: bailing out


However, if I type that exact same thing in the same terminal a second time, it'll load Addictive Drums without any trouble. I must also note that no other application is running (besides JACK Control). I blame it on my ****ty Pentium IV 1.8 GHz, 512MB RAM computer.
Yes, with a ****ty computer I'm able to run Addictive Drums better than some Windows computers with Intel D.
Last edited by NiTrO_FrEeZiNg at Aug 18, 2009,
#3
Quote by Axe Samurai
Man this must actually be fate, the 1st thing i had planned to do when i wake up tomorrow was download UbuntuStudio

I'm sure this will be helpful so thanks a lot!


Cool. Be sure to check it often though because I must have screwed up somewhere. As soon as people point my mistakes I'll be editing the main post. I've already edited it twice.

EDIT: Now I've edited it like 9 times.
Last edited by NiTrO_FrEeZiNg at Aug 18, 2009,