#1
My friend has a mesa/boogie (it's a smallish combo not sure exact model type, it has 3 channels if that helps) will no longer turn on at all. By that i mean no light on the front and no sound.

He's not played it for 6 months since he's been out the country so nothing obviously broke. I would guess it's not tubes since the standby light won't even turn on? is it likely to be something electric?

he's replacing the fuses tomorrow then taking it to a tech if that doesn't work unless someone has some flash of knowledge/inspiration here.
The only 6 words that can make you a better guitarist:

Learn theory
Practice better
Practice more
#2
why would you not play mesa boogie for 6 months at least let some tramp jam on it once !:O
#3
It's probably because it hasn't been played in 6 months. There's something you have to do when you haven't played an amp in a while but I can't recall at the moment.
E-peen:
Rhodes Gemini
Fryette Ultra Lead
Peavey 6505
THD Flexi 50

Gibson R0 Prototype
EBMM JP13 Rosewood
Fender CS Mary Kaye

WTLT

(512) Audio Engineering - Custom Pedal Builds, Mods and Repairs
#4
Check the fuse!! And replace it with the same kind if it is blown. Generally it's a 4 amp Slo-blo fuse.
If you start a reply with: I have never played one but I have heard good things about it! Your opinion is invalid.
#5
He was 'travelling' over in turkey and iraq for 6 months.

we checked the fuse and there was nothing obvious but we couldn't see through to the filament - as i say it'll be replaced tomorrow.

what was the magic thing you have to do having not played for a while?
The only 6 words that can make you a better guitarist:

Learn theory
Practice better
Practice more