#1
Just received My ceriatone 36. The person who shipped to me pulled all the tubes out so now a i have to put them in. Its 4 el84s 3 ec83s and a GZ34 rectifer. Need some hints about putting them back in. the el84 were easy. But do the ec83s go in a specific order? also when inserting the tubes do you have to push them down or is it more of a contact thing?

Thanks
#2
are the ec83s all the same brand? if so it doesnt matter what order. you have to push them down a little but dont force it if it doesnt slip in. just make sure the pins are lined up.
#3
Just wiggle them in, they're all the same tube and I think all of them are keyed so you can't accidentlay mis align the pins, just insert them a little bit, rotate until it clicks a bit and wiggle down.
Pain is an illusion.
Schecter Hellraiser C-1 w/ Seymour Duncan JB/Jazz Combo
Pitchblack | Bad Horsie 2 | DS-1 | BF-2 | ISP Decimator | DD6
YouTube Channel
#4
Quote by sesstreets
Just wiggle them in, they're all the same tube and I think all of them are keyed so you can't accidentlay mis align the pins, just insert them a little bit, rotate until it clicks a bit and wiggle down.



so u do have to wiggle them in. does that apply to the el84 s as well?

Thanks guys.
#5
When the pins line up, you should be able to wiggle and push the tubes down into the socket until you feel the glass hit the bottom of the socket. It's a very definite stop. All the tubes should be firmly seated such that you can't move them side to side.
#7
AGGG ive got a problem. No sound. Power On. Standby switched to on. I think its one of the EC83s, Because its all white on the top and its not glowing. should i buy a new one?
#8
You might need new tubes, but check the obvious first. Volume up on everything? Properly plugged in? No bad cables?
Tele - EP Booster - DLS - Big Muff - Ekko 616 - Rocker 30/AC15
#9
sometimes a preamp tube won't glow to bright. I would check again. Make sure the rectifier is snug too. You won't get any sound without that being properly seated.
Quote by shakin'cakes
First of all, I enjoy deathcore for it's complexity and it's the only genre heavy enough for me



Quote by Highway60Bob
I want an amp good for playing hippie tunes. I want it to be an actual amp, not a tube amp.
#11
yeah power light comes on. everything is plugged in. seated correctly. Does the fact that the top of that ECC83 is white instead of black mean anything. its flaky too.
#12
that could mean that the vacuum is broken. what do you mean by flaky?
Quote by shakin'cakes
First of all, I enjoy deathcore for it's complexity and it's the only genre heavy enough for me



Quote by Highway60Bob
I want an amp good for playing hippie tunes. I want it to be an actual amp, not a tube amp.
#13
Theres just a lot of white stuff at the top that none of the others have. I just pulled it out and its cracked. Everything else looks fine im going to go get one. I plug it in and if that doesnt work ill just take it to a shop.
#14
When you fix up your amp mind putting up some sound clips or a review perhaps? I've been looking into this amp for quite a bit.
Quote by drunkinkoala
you can be jesus.


Quote by Wesseem
most useless response i think i have ever seen on any forum ever.


Quote by Turkeyburger





Lolflag
#16
That sounds like a cracked vaccum tube.
Pain is an illusion.
Schecter Hellraiser C-1 w/ Seymour Duncan JB/Jazz Combo
Pitchblack | Bad Horsie 2 | DS-1 | BF-2 | ISP Decimator | DD6
YouTube Channel
#17
Quote by sesstreets
That sounds like a cracked vaccum tube.



Ohhh....hahaha. Nah i think i cracked it when i pulled it out. The tube got damaged in shipping. Problem fixed after a trip to local GC.
#19
yeah i made sure it was plugged into my cab. I may not know a lot about servicing my tube amps. But i know they have to be plugged in!!!

Like I said One of the tubes was damaged during shipping.
#20
Was it a power tube? ehhh... thats not the best idea because the other 3 (4 total el34's right?) will be of different brand and will require a different current to be optimized.

If it was a preamp tube then throw whatever in there, just make sure the first tube (v1 preamp tube) is of the best quality.
Pain is an illusion.
Schecter Hellraiser C-1 w/ Seymour Duncan JB/Jazz Combo
Pitchblack | Bad Horsie 2 | DS-1 | BF-2 | ISP Decimator | DD6
YouTube Channel
#21
Quote by sesstreets
Was it a power tube? ehhh... thats not the best idea because the other 3 (4 total el34's right?) will be of different brand and will require a different current to be optimized.

If it was a preamp tube then throw whatever in there, just make sure the first tube (v1 preamp tube) is of the best quality.
He already said it was a preamp tube that was the culprit.
Quote by Marty Friedman
Because I bend in such an unorthodox fashion; the notes kinda slide up and slide down...