#1
hello, I am having trouble with my Fender Frontman 65R w/ Reverb
As i was playing through a chorus/vibrato pedal the other day and not at high volume. Suddenly it started motor boating, I checked everything and tried to come up with a diagnosis, and eventually I fixed it. Now suddenly whenever I turn it on, there's just a hum and maybe a slight burn(or something) smell, and I turn it off there's a softer squeal. No idea what to do about this, if anyone can help me on this please.
#2
Quote by notzart
hello, I am having trouble with my Fender Frontman 65R w/ Reverb
As i was playing through a chorus/vibrato pedal the other day and not at high volume. Suddenly it started motor boating, I checked everything and tried to come up with a diagnosis, and eventually I fixed it. Now suddenly whenever I turn it on, there's just a hum and maybe a slight burn(or something) smell, and I turn it off there's a softer squeal. No idea what to do about this, if anyone can help me on this please.


Yeah, unusual smell (of any kind) coming from your amp is never a good thing.
Take it to a shop.

2001 Ernie Ball Music Man Axis Super Sport
2001 MIM Standard Strat
Peavey Classic 30 112 Combo.
My Gear
#3
Quote by jonmo1
Yeah, unusual smell (of any kind) coming from your amp is never a good thing.
Take it to a shop.



Yeah, take it to a shop.
Wait.



Roger Waters - 12th May!
#4
yup it just burned out, I'm gunna try my chances with a warranty(if i have one, i am not sure) before I take it into a shop, or just get a new one. It was a nice amp but not that nice.