#1
so i got anti-flag's the people or the gun on vinyl today and when i went to play it, it does not play at normal speed on 33 or 45. has anyone else had this problem? anyways to help it?
thanks in advance!
#5
Either you're wrong, the album is messed up, or your record player is messed up. Check with other albums and see if you have that issue.

Otherwise, I'd talk to the people you got it from and see what they have to say about it.

In the meantime, it should have come with a digital download, so just use that.
#6
Maybe Anti Flags suck is so powerful that it actually is starting to tear at the space time continuum and **** with time.

Trust me i have a PhD in Punk Physics and a BA in looking like I know what I'm talking about (very important if you want to be in a punk band.)
Quote by JohnnyV
I'm pretty sure the feeling i get when i blow my load on my computer screen is a f*ck of a lot different than when i shoot in on my girlfriend's face.


Music things

PRS SE Custom 24
Epiphone G400
Vox AC15C1
#8
Quote by skatinpunk
thanks guys


glad someone appreciated my help!
Quote by JohnnyV
I'm pretty sure the feeling i get when i blow my load on my computer screen is a f*ck of a lot different than when i shoot in on my girlfriend's face.


Music things

PRS SE Custom 24
Epiphone G400
Vox AC15C1
#9
so this morning i was messing with it and i put on the b side and it played regularly, so i flipped it back to a and it started working. thanks for all the entertaining anti-flag bashing! close dis ****!