#1
I havent been using my phaser pedal for about 2 weeks and now when i checked it and tried to turn it on my power light wasnt turning on.. does anybody know how to fix this or exactly what the problem is?
#2
Battery ran out?
Or do you use an adapter.....?

-Gibson LP VM
-Silvertone Kentucky Blue
-MXR CC Delay
-Ibanez TS-9
-Egnater Rebel 20
-Avatar 1x12

My rig is simple
Haha. UG's Chuck just said chuck. haha
You're not truly playing guitar unless you know theory.
#4
Naa battery didnt run out checked with other batteries. And no its not new.. ive had it for over a few months now.
#5
which one is the super phaser, the ph-?

depending on which one it is, it could be a whole rack of different things. and depending on which it is, it could be easy or hard to fix.
#6
Quote by jof1029
which one is the super phaser, the ph-?

depending on which one it is, it could be a whole rack of different things. and depending on which it is, it could be easy or hard to fix.


Its the ph-2
#7
ah, thats what i thought. at least it isnt the ph-3, if something is wrong with those it is impossible to fix since they are digital. the ph-2 isnt exactly simple on the inside though.

first step, try it with a power supply if you have one and make sure everything is plugged in right.

second step, open it up and see if there is anything noticibly wrong. broken wire, exploded cap, melted IC, etc.

third step, take pics of guts and i will compare it to mine. might be able to see if anything is noticibly wrong.