#1
So I just started fooling around with it. Biased my amp with it after I bias modded it, so that was current.

Then I set it to about 2000k ohms reading. Cause I was gonna read the ohms on some 500k control pots, you know just test it. Well it worked for the first pot. It was about 496ish then I twisted the knob and it read it changeing to lower ohms, then I took it off and did it again just to get a better hold and positioning. Then all it was reading was 1 on the screen. I touched it to the pot in the same spots, all it said was 1, I twisted the pot and tried different spots and it still just read 1. Then I switched it to 200k it read 1__. then 20k 1_. so on and so forth. and still read no ohms ratings no matter what it touched.

Whats the matter with it? is it something obvious? or is it totally messed?

Thanks in advanced.
Reinhardt 18 Head
H&K Tubemiester 18 head
Blue 6505+ head

TC Electronics G Major
MXR phase 90, Pigtronix Echolution 2
Digitech Whammy (5th gen)

ETB Infinity x2
ETB Yoda

Frust