#1
So yeah, ive had a small 25watt Fender Rumble bass amp for maybe a year now and everythings been fine with it. Only thing is that maybe a month ago i was playing it and suddenly the amp made a loud bang noise, followed by a strange feedback noise that got louder and louder until i turned off the amp. *Since then that noise has been happening more and more*

It cant be the bass guitar itself (I tried turning the volume off on the bass first) and it seems to be something wrong with the amp.

Im hoping to either sell the amp or trade it to get a better amp sometime in the future, so i need it in a prime condition lol,
If anyone has any info/solutions that would be heaps shibby (Y)
Last edited by NickTilyard at Oct 27, 2009,
#2
have you tried using it since?
First guess is a burst speaker so have a look at that, but I'm not really sure
Quote by UraniYum
Fuck you I'm trying to be caring and shit


Quote by Cb4rabid
Okay guys, I have a confession to make. Not really a confession since it's something that's been bugging me for awhile but I've always been in denial about it.

**** you gilly, it's not what you think
#3
"shibby" ...? lol

Does the amp still make the feedback noise when you turn it on?

If so, does it happen with no bass plugged in?

If not, what does happen?
Nope, no sig here.
Last edited by Mutant Corn at Oct 27, 2009,
#4
The noise only comes up when im playing shit, normally if i strum a bit hard or something. The speakers are fine, its just every now and then when i hit the string the amp will spaz out and ill drop nuts and jump to turn it off so it doesnt like blow the speakers.

Shibby is from the movie dude where my car haha
#5
Just remember: if I can understand you, I can help you better lol

Anyway, have you checked your guitar cable? I have a slightly faulty one that goes bang then starts hissing if I get it at the wrong angle.
Quote by UraniYum
Fuck you I'm trying to be caring and shit


Quote by Cb4rabid
Okay guys, I have a confession to make. Not really a confession since it's something that's been bugging me for awhile but I've always been in denial about it.

**** you gilly, it's not what you think
#6
^ +1, sounds like the cable. If not, maybe an input jack on the amp or bass.
Nope, no sig here.
#7
haha yeah sorry, its a really hard thing to understand.

I know for a fact its not the guitar leads (its happened while ive been using different leads), or the bass, so its deffinantly the bass amp.

Like i can play for a whole hour and it wont happen, it'll just randomly happen every now and then. The best way i can describe my problem is; A loud bang, then a really loud noise that keeps getting louder until i turn the power off directly at the amp.

Thats all i can really tell you guys, im deffinantly no expert on bass amps
#8
Then my guess would be the input on the amp.
If so then I'm not sure how to fix it and if not then I'm not sure what it is (sorry)
With an amp of that price range, you will have to work out if it is worth paying to get it checked out and fixed or if it is just worth getting a different amp.
Quote by UraniYum
Fuck you I'm trying to be caring and shit


Quote by Cb4rabid
Okay guys, I have a confession to make. Not really a confession since it's something that's been bugging me for awhile but I've always been in denial about it.

**** you gilly, it's not what you think