#1
I really need your help guys....
After modding my Boss MT-2 i can't figure out, how the input jack was wired
Im totally frustrated because nothing works right
does somebody has a picture of the input section of the mt2???

Thanks in advance
Guitars/Basses:
-Ibanez SZ-520QM (D-Sonic/Air Norton)
-Ibanez RG-370
-ESP ltd B-55
Amps/Effects/Rig:
-Engl E530 + 930/60 Poweramp
-POD X3L
#2
a search on google for "MT-2 diagram" yields plenty of schematics, but they're above my understanding

but generally the ground goes to the sleeve, the negative goes to the ring and whichever wire connects the signal to the board goes to the tip.

but I'm having trouble finding a simple wiring diagram to help you figure out which is which
#3
thanks man got it mostly
do you know if the switch is connected to the tip of the input??
Guitars/Basses:
-Ibanez SZ-520QM (D-Sonic/Air Norton)
-Ibanez RG-370
-ESP ltd B-55
Amps/Effects/Rig:
-Engl E530 + 930/60 Poweramp
-POD X3L
#4
I would think so. I dunno how the mt-2 is wired, but if it's true bypass it's probably like this


(taken from BYOC forum)


I believe the 2 (to ground) lug could be soldered directly to the sleeve lug on your input. as in have one wire going from the sleeve to the #2 lug and have another going to wherever it goes on the pcb. at least that's how it's been on the two pedals I've built
Last edited by The4thHorsemen at Nov 5, 2009,
#5
^the boss pedals don't use true bypass, so that doesn't apply in ths case..

and TS, I'm not really sure what wires you've disconnected, what you've done to it, or what you've re-attached to what... so I don't really know where to go with helping you put it back together for now...

a little more detail, if possible?
#6
Quote by james4
^the boss pedals don't use true bypass, so that doesn't apply in ths case..

and TS, I'm not really sure what wires you've disconnected, what you've done to it, or what you've re-attached to what... so I don't really know where to go with helping you put it back together for now...

a little more detail, if possible?


oh, my bad.
#8
i guess i attached them right so the problem has to be somewhere else...
but thanks for the help guys, i was absolutely pissed off.

I was doing the Sustainiac Tri Gain Mod by Monte Allums and got it working, sounded pretty nice, but theres some problem with the switch guess its broken or something
Guitars/Basses:
-Ibanez SZ-520QM (D-Sonic/Air Norton)
-Ibanez RG-370
-ESP ltd B-55
Amps/Effects/Rig:
-Engl E530 + 930/60 Poweramp
-POD X3L
#9
btw just for technical interest:
how is it possible that theres only one wire going to the output jack?
is it grounded via the chassis or what??
Guitars/Basses:
-Ibanez SZ-520QM (D-Sonic/Air Norton)
-Ibanez RG-370
-ESP ltd B-55
Amps/Effects/Rig:
-Engl E530 + 930/60 Poweramp
-POD X3L
#10
Quote by LiveinBerkum
btw just for technical interest:
how is it possible that theres only one wire going to the output jack?
is it grounded via the chassis or what??


that sounds logical